Bug 135205 - Kfloppy fails to create filesystem (DOS) to floppy
Kfloppy fails to create filesystem (DOS) to floppy
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-10 05:41 EDT by Jan-Petter Vainionpaa
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 10:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan-Petter Vainionpaa 2004-10-10 05:41:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3)
Gecko/20040921

Description of problem:
Kfloppy fails to create filesystem (DOS) to floppy when formatting it.

Selected options (Quick/full -format, verify integrity, label) does
not seem to have any influence to the result.

Minor thing is, that kfloppy does not show any kind of progress
information during formatting. Application dialog is grayed, and blue
progress bar does not increase.

This problem occures in both i386 and amd64 versions of Fedora Core 2.

I have two i386 machines and one amd64 machine, and this error occures
in all of them, so it most likely is not a hardware issue.

Version-Release number of selected component (if applicable):
kdeutils-3.2.2-3

How reproducible:
Always

Steps to Reproduce:
1. Start kfloppy (for example from shell by typing $kfloppy &
2. Set basic settings as follows:
 - Floppy Drive: Primary
 - Size: 3.5" 1.4MB
 - Filesystem: DOS

additional options 

 - Full format selected
 - Verify integrity checked
 - Label checked

3. Start formatting
4. After formatting is ready (a bit difficult to know, because
progress bar does not work :)) try to moutn the floppy from shell
with command $mount /mnt/floppy


Actual Results:  The floppy should be able to be mounted after
formatting, and to be accessible for reading and writing.

Expected Results:  $mount /mnt/floppy
mount: I could not determine the filesystem type, and none was specified

Additional info:


Filesystem can be created to floppy manually by giving the command
$mkdosfs /dev/fd0.

gfloppy does not seem to suffer this problem, it just works.
Comment 1 Ngo Than 2004-10-14 10:38:09 EDT
it's fixed in KDE-3.3.1, which you could download from ftp.kde.org for
FC2.

Note You need to log in before you can comment on or make changes to this bug.