Bug 135208 - totem crashes on wrong url
Summary: totem crashes on wrong url
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: totem
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Monty
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-10 15:32 UTC by Rahul Sundaram
Modified: 2013-10-20 22:41 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-10-27 10:18:55 UTC


Attachments (Terms of Use)

Description Rahul Sundaram 2004-10-10 15:32:45 UTC
Description of problem:


Totem crashes immediately if I give a wrong url

Version-Release number of selected component (if applicable):

totem-0.99.17-1

How reproducible:


Steps to Reproduce:
1. open totem player
2. open url "mirror.fluendo.com:8800"
( I know the url above is supposed to include http:// but totem
shouldnt crash without it)
  
Actual results:

Immediate crash 

Expected results:

let me know its a non existant url or add http:// automatically maybe?


Additional info:

gstreamer-0.8.7-2

Comment 1 Colin Walters 2004-10-13 20:13:51 UTC
Works for me with 0.99.18-2; can you still reproduce?


Comment 2 Rahul Sundaram 2004-10-18 19:56:00 UTC

Ok. after running the update totem doesnt crash if given a wrong url.
It just ignores this "mirror.fluendo.com:8800". I believe that a error
dialog information that this is a non existant url would be more
appropriate

I tried "http://fluendo.com:8800". It hangs. I had to force quit the
application and then it wouldnt start again. I restarted the machine.
Was able to start totem now. gave url
"http://mirror.fluendo.com:8800". totem said its streaming but didnt
show anything for a few mins. was able to see a blue screen after
sometime.

tried again "http://fluendo.com:8800".was able to reproduce the
earlier behaviour precisely. totem from the command line just returns
the shell back immediately with no output.

totem version is 0.99-19_1

If you require any further information please ask






Comment 3 Rahul Sundaram 2004-10-18 20:09:34 UTC
One more thing. force quitting totem leaves a process running. I
killed it as root and restarted the application successfully

Comment 4 Rahul Sundaram 2005-08-13 00:29:12 UTC

ok. I can reproduce this problem with totem-1.1.3-1. This should definitely do
better

Comment 5 Bastien Nocera 2006-10-27 10:18:55 UTC
Just test on FC6, and I definitely don't get a crash.

As for making the Open Location more intelligent, it's already upstream at:
http://bugzilla.gnome.org/show_bug.cgi?id=320521


Note You need to log in before you can comment on or make changes to this bug.