Bug 135208 - totem crashes on wrong url
totem crashes on wrong url
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Monty
Depends On:
  Show dependency treegraph
Reported: 2004-10-10 11:32 EDT by Rahul Sundaram
Modified: 2013-10-20 18:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-27 06:18:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2004-10-10 11:32:45 EDT
Description of problem:

Totem crashes immediately if I give a wrong url

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. open totem player
2. open url "mirror.fluendo.com:8800"
( I know the url above is supposed to include http:// but totem
shouldnt crash without it)
Actual results:

Immediate crash 

Expected results:

let me know its a non existant url or add http:// automatically maybe?

Additional info:

Comment 1 Colin Walters 2004-10-13 16:13:51 EDT
Works for me with 0.99.18-2; can you still reproduce?
Comment 2 Rahul Sundaram 2004-10-18 15:56:00 EDT

Ok. after running the update totem doesnt crash if given a wrong url.
It just ignores this "mirror.fluendo.com:8800". I believe that a error
dialog information that this is a non existant url would be more

I tried "http://fluendo.com:8800". It hangs. I had to force quit the
application and then it wouldnt start again. I restarted the machine.
Was able to start totem now. gave url
"http://mirror.fluendo.com:8800". totem said its streaming but didnt
show anything for a few mins. was able to see a blue screen after

tried again "http://fluendo.com:8800".was able to reproduce the
earlier behaviour precisely. totem from the command line just returns
the shell back immediately with no output.

totem version is 0.99-19_1

If you require any further information please ask

Comment 3 Rahul Sundaram 2004-10-18 16:09:34 EDT
One more thing. force quitting totem leaves a process running. I
killed it as root and restarted the application successfully
Comment 4 Rahul Sundaram 2005-08-12 20:29:12 EDT

ok. I can reproduce this problem with totem-1.1.3-1. This should definitely do
Comment 5 Bastien Nocera 2006-10-27 06:18:55 EDT
Just test on FC6, and I definitely don't get a crash.

As for making the Open Location more intelligent, it's already upstream at:

Note You need to log in before you can comment on or make changes to this bug.