Bug 1352087 - nova_ec2 configured in haproxy config while the backend services are down
Summary: nova_ec2 configured in haproxy config while the backend services are down
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 10.0 (Newton)
Assignee: Michele Baldessari
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-01 14:36 UTC by Marius Cornea
Modified: 2016-12-14 15:42 UTC (History)
14 users (show)

Fixed In Version: puppet-tripleo-5.0.0-0.20160818125555.a812fdb.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:42:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Marius Cornea 2016-07-01 14:36:42 UTC
Description of problem:
The nova_ec2 is configured in haproxy config while the backend services are down:


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-2.0.0-12.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud
2. grep -A5 ec2 /etc/haproxy/haproxy.cfg

Actual results:
[root@ctrl-r00-00 heat-admin]# grep -A5 ec2 /etc/haproxy/haproxy.cfg 
listen nova_ec2
  bind 10.0.0.5:8773 transparent
  bind 172.16.18.25:8773 transparent
  server ctrl-r00-00 10.0.0.10:8773 check fall 5 inter 2000 rise 2
  server ctrl-r01-01 10.0.0.11:8773 check fall 5 inter 2000 rise 2
  server ctrl-r02-02 10.0.0.12:8773 check fall 5 inter 2000 rise 2

[root@ctrl-r00-00 heat-admin]# curl 10.0.0.10:8773
curl: (7) Failed connect to 10.0.0.10:8773; Connection refused

Expected results:
According to https://review.openstack.org/#/c/316360/ we should expect Nova EC2 to be remved so I expect it to be removed from haproxy as well.

Additional info:

Comment 2 Michele Baldessari 2016-07-26 19:32:49 UTC
This landed in OSP10 via https://review.openstack.org/#/c/316361/

Comment 3 Fabio Massimo Di Nitto 2016-07-27 03:51:20 UTC
(In reply to Michele Baldessari from comment #2)
> This landed in OSP10 via https://review.openstack.org/#/c/316361/

Shouldn't this bug be in POST if we have a patch upstream?

Comment 9 errata-xmlrpc 2016-12-14 15:42:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.