Bug 1352096 - bash completion for the more command does not parse files with spaces properly
Summary: bash completion for the more command does not parse files with spaces properly
Keywords:
Status: CLOSED DUPLICATE of bug 1296366
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: util-linux
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Karel Zak
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-01 15:13 UTC by Zdenek Pytela
Modified: 2019-11-14 08:35 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-07 10:30:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Zdenek Pytela 2016-07-01 15:13:31 UTC
Description of problem:
bash completion for the more command does not parse files containing spaces properly


Version-Release number of selected component (if applicable):
bash-completion-2.1-6.el7.noarch


How reproducible:
always


Steps to Reproduce:
1. touch "hello world"
2. more h<tab> <tab>


Actual results:
$ more h
hello  world


Expected results:
$ more hello\ world


Additional info:
in RHEL 6 (epel based package) and Fedora this works as expected
in RHEL 7, for example cat and less work fine; even with default minimal completion it works better

$ complete -p more
complete -F _more_module more
$ complete -p less
complete -F _longopt less
$ complete -p cat
complete -F _longopt cat

$ complete -r less
$ complete -p less
complete -F _minimal less
$ less hello\ world
<works>

Comment 1 Siteshwar Vashisht 2016-07-04 08:58:35 UTC
Completions for more command are provided by util-linux package. Reassigning to util-linux component.

This issue should be fixed by backporting https://git.kernel.org/cgit/utils/util-linux/util-linux.git/commit/?id=ce3e6b15e2c4478b2df9a7016c168b16325abfb0

Comment 2 Karel Zak 2016-07-07 10:30:18 UTC

*** This bug has been marked as a duplicate of bug 1296366 ***


Note You need to log in before you can comment on or make changes to this bug.