Bug 1352137 - Sierra EM7455 unable to connect
Summary: Sierra EM7455 unable to connect
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ModemManager
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-01 18:23 UTC by Nathaniel Nutter
Modified: 2016-11-15 17:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-15 17:24:17 UTC


Attachments (Terms of Use)
Logs while attempting to connect to WWAN (4.68 KB, text/plain)
2016-07-01 18:23 UTC, Nathaniel Nutter
no flags Details
Logs from NetworkManager when connecting (3.83 KB, text/plain)
2016-07-17 17:56 UTC, Nathaniel Nutter
no flags Details

Description Nathaniel Nutter 2016-07-01 18:23:00 UTC
Created attachment 1175079 [details]
Logs while attempting to connect to WWAN

Description of problem: I am unable to connect cellular modem (WWAN).


Version-Release number of selected component (if applicable):

ModemManager-1.6-0.3.rc3.fc24.x86_64
libqmi-1.14.2-1.fc24.x86_64
libmbim-1.12.4-2.fc24.x86_64


How reproducible:  100%


Steps to Reproduce:
1. Insert SIM of known-working account (T-Mobile).
2. Setup US-based, T-Mobile, LTE account.
3. Try to connect.

Actual results: "Nothing" happens.


Expected results: Cellular modem connects.


Additional info:

I've attached (brief) logs from when I try to connect.  There are messages from selinux and firewalld which may just be noise.  For example, I `setenforce permissive` and still had the issue.  I also found an upstream bug that I believe may be the cause,

Support for Sierra EM7455 on Lenovo Carbon X1 carbon 4th gen
https://bugs.freedesktop.org/show_bug.cgi?id=96623

As far as I can tell there is a patch available on a non-mainline branch but I have not tested it in my situation.  I have a T460s not Carbon X1 but it's the same modem.

Comment 1 Nathaniel Nutter 2016-07-08 01:28:21 UTC
The upstream bug is believed to be fixed.

From https://bugs.freedesktop.org/show_bug.cgi?id=96623#c7,

This issue is now fixed when using MM 1.5.993, libqmi 1.16.0 and libmbim 1.14.0, all including the QMI over MBIM support:

https://lists.freedesktop.org/archives/modemmanager-devel/2016-July/003177.html
https://lists.freedesktop.org/archives/libqmi-devel/2016-July/001638.html
https://lists.freedesktop.org/archives/libmbim-devel/2016-July/000752.html

Additionally, this NCM driver patch in the kernel is also needed, which should be available in the next stable Linux kernel release:

http://www.spinics.net/lists/linux-usb/msg143399.html

Comment 2 Nathaniel Nutter 2016-07-17 17:28:36 UTC
After installing libqmi, libmbim, and ModemManager from Rawhide my modem was able to connect.  I'm still haven't got out over the modem but that's probably a config issue.

$ sudo dnf install fedora-repos-rawhide
$ sudo dnf install --enablerepo rawhide --best --allowerasing libqmi libmbim ModemManager

Comment 3 Nathaniel Nutter 2016-07-17 17:56:01 UTC
Created attachment 1180824 [details]
Logs from NetworkManager when connecting

I've attached logs showing that the modem seems to be working even though I can't ping gateway or DNS servers.

Comment 4 Nathaniel Nutter 2016-08-04 16:39:08 UTC
The last piece to get the modem working reliably was to install a newer kernel,

$ sudo dnf install --enablerepo rawhide --best --allowerasing kernel

With kernel, libqmi, libmbim, and ModemManager from rawhide the cellular modem is working fine.

Comment 5 D. G. 2016-08-28 20:53:03 UTC
I can confirm that those fixes work on Lenovo X1 Carbon 4th gen.

Comment 6 David Jao 2016-08-31 23:37:13 UTC
Nathaniel (or any one else): The modem works fine on my T460s following your instructions, but afterwards if I try to suspend and resume, the modem stops working with no way to recover other than a reboot. Do you have this problem too?

Comment 7 Nathaniel Nutter 2016-09-01 01:51:02 UTC
David Jao, I am not aware of any issues relating to suspend/resume.  I rarely shutdown my laptop and am routinely using the cellular modem after waking from sleep.

Comment 8 David Jao 2016-09-02 02:02:13 UTC
Thanks Nathaniel. After updating my system to the latest F24 (a few hundred packages), the modem works fine on suspend/resume; however it does take a minute or so to reappear in NetworkManager after resume. Also, the modem number increments by 1 in ModemManager each time it resumes (e.g. /org/freedesktop/ModemManager1/Modem/0 becomes /org/freedesktop/ModemManager1/Modem/1 becomes /org/freedesktop/ModemManager1/Modem/2 ...)

Comment 9 Lubomir Rintel 2016-11-15 17:24:17 UTC
(In reply to David Jao from comment #8)
> Thanks Nathaniel. After updating my system to the latest F24 (a few hundred
> packages), the modem works fine on suspend/resume; however it does take a
> minute or so to reappear in NetworkManager after resume. Also, the modem
> number increments by 1 in ModemManager each time it resumes (e.g.
> /org/freedesktop/ModemManager1/Modem/0 becomes
> /org/freedesktop/ModemManager1/Modem/1 becomes
> /org/freedesktop/ModemManager1/Modem/2 ...)

Yeah, that's expected. MM needs time to re-probe the modems after a resume and the modems also take time to boot up.

Closing this as it's fixed with the current release.


Note You need to log in before you can comment on or make changes to this bug.