Bug 1352140 - [regression] [armv7] USB broken on BananaPi with kernel 4.6.3
Summary: [regression] [armv7] USB broken on BananaPi with kernel 4.6.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2016-07-01 18:49 UTC by James Ettle
Modified: 2016-10-23 22:48 UTC (History)
10 users (show)

Fixed In Version: kernel-4.8.2-300.fc25 kernel-4.7.9-200.fc24 kernel-4.7.9-100.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-22 17:19:53 UTC


Attachments (Terms of Use)
dmesg from working kernel-4.5.7-300.fc24.armv7hl (31.88 KB, text/plain)
2016-07-01 18:49 UTC, James Ettle
no flags Details
dmesg from broken kernel-4.6.3-300.fc24.armv7hl (28.27 KB, text/plain)
2016-07-01 18:50 UTC, James Ettle
no flags Details

Description James Ettle 2016-07-01 18:49:41 UTC
Created attachment 1175084 [details]
dmesg from working kernel-4.5.7-300.fc24.armv7hl

Description of problem:
BananaPi is an Allwinner A20/sunxi device.

The USB host controller is broken with kernel 4.6.3. I ehci-platform is loaded but I can't find any evidence the hardware's being activated, and nothing actually works on the USB ports.

Works fine with 4.5.7.

FAULTY:  kernel-4.6.3-300.fc24.armv7hl
WORKING: kernel-4.5.7-300.fc24.armv7hl

Attached are dmesgs from both kernels.

Comment 1 James Ettle 2016-07-01 18:50:25 UTC
Created attachment 1175085 [details]
dmesg from broken kernel-4.6.3-300.fc24.armv7hl

Comment 2 Clive Messer 2016-07-18 23:33:47 UTC
Any progress on this?

Comment 3 Clive Messer 2016-07-19 17:58:23 UTC
The culprit would seem to be....

-CONFIG_MFD_AXP20X=y
+CONFIG_MFD_AXP20X=m
+CONFIG_MFD_AXP20X_I2C=m
+CONFIG_MFD_AXP20X_RSB=m

ie. the axp20x module needs to be "force" loaded, as it is not auto loaded and isn't built into kernel anymore. (Well, actually the axp20x-i2c module, as that seems to be where the AXP209 is recognised. (It looks like the axp20x driver has had the I2C component, split into a separate module since 4.5 series kernels.)

For now I just added an /etc/dracut.conf.d/banana.conf

with contents....
force_drivers+="axp20x_i2c"
..... and rebuilt 4.6.4 initramfs from a working 4.5.7 kernel. 

Which had gotten my BananaPi's and Pro's back onto the network using USB wi-fi, now that USB is functional again.

Comment 4 James Ettle 2016-07-20 05:57:50 UTC
I confirm that workaround works.

Comment 5 Peter Robinson 2016-09-08 09:46:52 UTC
Thanks Clive, will take a look shortly.

Comment 6 Filip Bartmann 2016-10-12 09:57:27 UTC
I have this problem on Banana Pi R1 with Fedora 25 Beta too. Is there any way to make it work with Fedora 25?

Comment 7 Peter Robinson 2016-10-18 14:27:54 UTC
(In reply to Filip Bartmann from comment #6)
> I have this problem on Banana Pi R1 with Fedora 25 Beta too. Is there any
> way to make it work with Fedora 25?

can you test the 4.8.2 kernel and let me know if that works?

http://koji.fedoraproject.org/koji/buildinfo?buildID=810665

Comment 8 Paul Whalen 2016-10-18 20:42:19 UTC
Working with 4.8.2-300.fc25 on the Banana Pi.

Comment 9 Peter Robinson 2016-10-19 09:41:02 UTC
So I've pushed the config changes to F24/23 so it'll be in the next kernel post 4.7.8 (likely 4.8.x) for those releases and 4.8.2-300.fc25 for F-25

Comment 10 Fedora Update System 2016-10-19 19:55:17 UTC
kernel-4.8.2-300.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2597082b5

Comment 11 Fedora Update System 2016-10-20 16:24:45 UTC
kernel-4.8.2-300.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-10-22 02:24:54 UTC
kernel-4.7.9-100.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c3558808cd

Comment 13 Fedora Update System 2016-10-22 11:54:22 UTC
kernel-4.7.9-200.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-db4b75b352

Comment 14 Fedora Update System 2016-10-22 17:19:53 UTC
kernel-4.7.9-200.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-10-23 22:48:35 UTC
kernel-4.7.9-100.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.