Bug 135222 - new directory creation causes crash
new directory creation causes crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-10 18:00 EDT by Jim Cornette
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 21:14:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2004-10-10 18:00:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
When saving a file, it is sometimes desired to create a new directory.
The new directory creation causes the browser to crash. The new
directory appears in the gtk2 version file chooser, but changing to
the directory causes a crash. Also, the newly "created directory" is
not actually created.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. find item to save to local directory
2. decide that this item should get a new location created.
3. create directory
4. click on directory
5. notice mozilla crashed
    

Actual Results:  1. found alright
2. no brain cells lost
3. started to "create" directory, name of directory prsent in chooser
4. kaboom, no more mozilla present
5. searching for "created" directory, no new directory actually created


Expected Results:  I expected the directory to be actually created and
to not have mozilla crash because the directory was not actually created.

Additional info:

As a personal preference, I like to see the absolute path displayed
and not just the target directory. The older behavior was a lot more
user friendly. I hope to see this behavior return soon.
Comment 1 Jim Cornette 2004-10-11 21:14:05 EDT
Testing again with mozilla-1.7.3-12 results in normal creation of new
directories. I was able to create and save files within a new folder
and did not have a crash with mozilla.

Bug being closed.

Note You need to log in before you can comment on or make changes to this bug.