Bug 1352244 - aisleriot can't find all icons in theme under wayland but fine under gtk
Summary: aisleriot can't find all icons in theme under wayland but fine under gtk
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: aisleriot
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-02 23:01 UTC by Trever Adams
Modified: 2017-05-09 02:13 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-05-09 02:13:48 UTC


Attachments (Terms of Use)
Don't try non-existant names (2.51 KB, patch)
2016-07-03 00:49 UTC, Trever Adams
no flags Details | Diff
Better patch in that it also fixes the can drop icon (3.38 KB, patch)
2016-07-03 02:09 UTC, Trever Adams
no flags Details | Diff

Description Trever Adams 2016-07-02 23:01:24 UTC
Description of problem:
(sol:5613): Gdk-WARNING **: gdkcursor-wayland.c:170: Unable to load openhand from the cursor theme

(sol:5613): Gdk-WARNING **: gdkcursor-wayland.c:170: Unable to load closedhand from the cursor theme


Version-Release number of selected component (if applicable):
aisleriot-3.20.2-1.fc24.x86_64

Comment 1 Trever Adams 2016-07-02 23:50:32 UTC
It appears it is loading hand1 and grabbing instead. The problem is, in Wayland setups these are not displayed.

Comment 2 Trever Adams 2016-07-03 00:49 UTC
Created attachment 1175444 [details]
Don't try non-existant names

gdk_cursor_new_from_name is now preferred over gdk_cursor_new_for_display.
It appears that gdk_cursor_new_from name breaks if the name is not found when used under Wayland, so reorder things.

Comment 3 Trever Adams 2016-07-03 02:09 UTC
Created attachment 1175445 [details]
Better patch in that it also fixes the can drop icon

Comment 4 Trever Adams 2016-10-17 10:36:38 UTC
https://bugzilla.gnome.org/show_bug.cgi?id=773077 should fix part of this problem. The rest are nice to have, but not critical to the functioning of the app.

Comment 5 Christian Persch (GNOME) 2016-10-17 16:29:08 UTC
I've pushed the 2nd path in the upstream git.

Comment 6 Trever Adams 2016-10-17 19:15:51 UTC
Thank you!

Comment 7 Leslie Satenstein 2016-11-26 20:14:29 UTC
Month 7 t'il now, and so far, it has not made it into the fixes for Fedora 25.

Please investigate why this bug has not made it to Fedora 25 release version

Comment 8 Leslie Satenstein 2017-05-08 14:26:10 UTC
Updates have corrected the session
Thank you

Please close

Comment 9 Trever Adams 2017-05-09 02:13:48 UTC
It has been fixed.


Note You need to log in before you can comment on or make changes to this bug.