Bug 1352263 - qemu:///session connections don't get virtlogd started by user's libvirtd
Summary: qemu:///session connections don't get virtlogd started by user's libvirtd
Keywords:
Status: CLOSED DUPLICATE of bug 1351995
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-03 05:09 UTC by Dimitris
Modified: 2016-07-04 08:41 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-04 08:41:39 UTC


Attachments (Terms of Use)

Description Dimitris 2016-07-03 05:09:53 UTC
Description of problem:

Just updated F23 to F24, so libvirt upgraded from 1.2 to 1.3.  I have been using a couple of work VMs on this system, both under the qemu:///session connection.

When I try to start a guest, I get this error:

error: Failed to start domain <name>
error: Failed to connect socket to '/run/user/1000/libvirt/virtlogd-sock': Connection refused

I can work around this by manually running virtlogd (will probably write a user unit file, if I can figure that out, so I don't have to remember to do that every time)

Version-Release number of selected component (if applicable):

1.3.3.1-4.fc24

How reproducible:

every time

Steps to Reproduce:
1. Start a qemu:///session guest
2. Guests fail to start with the error above

Actual results:

Requires workaround: manually run virtlogd

Expected results:

This is a regression, previously (under 1.2, so presumably no virtlogd dependency) no such workaround was necessary.

Additional info:

There is actually one more stumbling block (an apparent capabilities problem) which I have to work around before the guest can start.  Once I have that bug entered I'll cross-reference both of them.

Comment 1 Dimitris 2016-07-03 05:17:53 UTC
For completeness, the other regression I mentioned in the description is in bug 1352265.

Comment 2 Daniel Berrangé 2016-07-04 08:41:39 UTC
Failure to start virtlogd is caused by broken audit-libs - you must have 2.6.2 or 2.6, but *not* 2.6.1 which is fubar

*** This bug has been marked as a duplicate of bug 1351995 ***


Note You need to log in before you can comment on or make changes to this bug.