Bug 1352270 - packaging: error: %pretrans(php-horde-horde-5.2.10-1.el7.noarch) scriptlet failed, exit status 127
Summary: packaging: error: %pretrans(php-horde-horde-5.2.10-1.el7.noarch) scriptlet fa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: php-horde-horde
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-03 07:59 UTC by Jean-Philippe Pialasse
Modified: 2016-09-27 03:51 UTC (History)
1 user (show)

Fixed In Version: php-horde-horde-5.2.12-1.fc25 php-horde-horde-5.2.12-1.fc23 php-horde-horde-5.2.12-1.fc24 php-horde-horde-5.2.12-1.el6 php-horde-horde-5.2.12-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 18:10:19 UTC
Type: Bug


Attachments (Terms of Use)
anaconda log (613.60 KB, text/plain)
2016-07-03 08:00 UTC, Jean-Philippe Pialasse
no flags Details

Description Jean-Philippe Pialasse 2016-07-03 07:59:17 UTC
Description of problem:
trying to include the Horde package in the install process of anaconda for centos7 based distro SME server

Version-Release number of selected component (if applicable):
php-horde-horde-5.2.10-1.el7.noarch

How reproducible:
each time


Steps to Reproduce:
1. create a new comp.xml for anaconda including php-horde-horde , 
2. put the rpm and all dependencies including php-horde-Horde-Role-1.0.1-4.el7.noarch in the Packages folder for the iso
3. create the iso
4. launch anaconda to install

Actual results:
Anaconda fails in the middle of the process with the following in logs

15:01:40,540 INFO packaging: ==== start rpm scriptlet logs ====
15:01:40,540 INFO packaging: warning: filesystem-3.2-20.el7.x86_64: Header V3 RSA/SHA256 Signature, key ID f4a80eb5: NOKEY
15:01:40,540 INFO packaging: warning: php-horde-horde-5.2.10-1.el7.noarch: Header V3 RSA/SHA256 Signature, key ID 352c64e5: NOKEY
15:01:40,541 INFO packaging: error: %pretrans(php-horde-horde-5.2.10-1.el7.noarch) scriptlet failed, exit status 127
15:01:40,541 INFO packaging: ==== end rpm scriptlet logs ====

Expected results:
Anaconda finishing the complete installation

Additional info:
the pre scriptlet contains this:
if [ -d %{pear_hordedir}/static -a ! -L %{pear_hordedir}/static ]
then
 save=%{pear_hordedir}/static.rpmsave
 while [ -e $save ]
 do  save=${save}_
 done
 mv %{pear_hordedir}/static $save
fi


which means it was requiring php-horde-Horde-Role-1.0.1-4.el7.noarch to be installed prior , maybe this command should be somewhere else in the spec file.

Comment 1 Jean-Philippe Pialasse 2016-07-03 08:00:53 UTC
Created attachment 1175458 [details]
anaconda log

Comment 2 Jean-Philippe Pialasse 2016-07-03 08:14:13 UTC
maybe the following is needed:

Requires(pretrans): php-horde-Horde-Role

Comment 3 Remi Collet 2016-07-03 08:21:52 UTC
This script have to be %pretrans, to be run before any other horde packages installation.

The real scriplet is (all macro are extended, so no need for horde_role)

pretrans scriptlet (using /bin/sh):
if [ -d /usr/share/horde/static -a ! -L /usr/share/horde/static ]
then
  save=/usr/share/horde/static.rpmsave
  while [ -e $save ]
  do  save=${save}_
  done
  mv /usr/share/horde/static $save
fi

BTW, I thin can be caused by missing shell, probably need to converted to a lua script (something I really don't like)

Comment 4 Jean-Philippe Pialasse 2016-07-26 03:37:39 UTC
suggesting something like this ?

%pretrans <lua>
require 'posix'
if  ( ( posix.stat("/usr/share/horde/static", "type") == 'directory') and not ( posix.stat("/usr/share/horde/static", "type") == 'link' ) ) then
  save = "/usr/share/horde/static.rpmsave"
  while   (posix.stat(save, "type") == 'file') do
        save = save .. "_"
  end
  os.rename("/usr/share/horde/static", save)
end

Comment 5 Jean-Philippe Pialasse 2016-07-26 03:40:32 UTC
of course "/usr/share/horde/static" might be substituted by

rpm.expand("%{pear_hordedir}")

Comment 6 Fedora Update System 2016-09-07 08:00:12 UTC
php-horde-horde-5.2.12-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5763cacac0

Comment 7 Fedora Update System 2016-09-07 08:00:20 UTC
php-horde-horde-5.2.12-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c5b434fc32

Comment 8 Fedora Update System 2016-09-07 08:00:25 UTC
php-horde-horde-5.2.12-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-665fb50899

Comment 9 Fedora Update System 2016-09-07 08:00:29 UTC
php-horde-horde-5.2.12-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bf8d17758f

Comment 10 Fedora Update System 2016-09-07 08:00:33 UTC
php-horde-horde-5.2.12-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f71c0650c3

Comment 11 Fedora Update System 2016-09-09 06:29:40 UTC
php-horde-horde-5.2.12-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c5b434fc32

Comment 12 Fedora Update System 2016-09-09 17:16:31 UTC
php-horde-horde-5.2.12-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-665fb50899

Comment 13 Fedora Update System 2016-09-09 17:19:02 UTC
php-horde-horde-5.2.12-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f71c0650c3

Comment 14 Fedora Update System 2016-09-09 17:58:04 UTC
php-horde-horde-5.2.12-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5763cacac0

Comment 15 Fedora Update System 2016-09-12 15:29:49 UTC
php-horde-horde-5.2.12-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bf8d17758f

Comment 16 Fedora Update System 2016-09-13 18:10:17 UTC
php-horde-horde-5.2.12-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2016-09-21 20:22:37 UTC
php-horde-horde-5.2.12-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-09-22 00:25:45 UTC
php-horde-horde-5.2.12-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2016-09-27 03:47:17 UTC
php-horde-horde-5.2.12-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2016-09-27 03:51:15 UTC
php-horde-horde-5.2.12-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.