Bug 1352272 - Kernel 4.6.3-300 broken on radeon GPU support
Summary: Kernel 4.6.3-300 broken on radeon GPU support
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-03 09:10 UTC by Knud Christiansen
Modified: 2017-04-07 19:53 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-07 19:53:46 UTC
Type: Bug


Attachments (Terms of Use)
output from dmesg kernel 4.6.3-300 (70.99 KB, text/plain)
2016-07-03 09:10 UTC, Knud Christiansen
no flags Details
output from dmesg kernel 4.5.7-300 (69.10 KB, text/plain)
2016-07-03 09:11 UTC, Knud Christiansen
no flags Details

Description Knud Christiansen 2016-07-03 09:10:17 UTC
Created attachment 1175461 [details]
output from dmesg kernel 4.6.3-300

Description of problem:
Radeon GPU support broken, default back to VESA

Version-Release number of selected component (if applicable):
Kernel 4.6.3-300

How reproducible:
Install/update to from 4.5.7-300 to 4.6.3-300, reboot

Steps to Reproduce:
1.
2.
3.

Actual results:
Screen resolution is 1024*768

Expected results:
1366*768

Additional info:
Reboot with kernel 4.5.7-300 works ok

Comment 1 Knud Christiansen 2016-07-03 09:11:29 UTC
Created attachment 1175462 [details]
output from dmesg kernel 4.5.7-300

from kernel 4.5.7-300

Comment 2 Knud Christiansen 2016-07-23 10:39:35 UTC
Kernel 4.6.4-301 has still this bug

Comment 3 Knud Christiansen 2016-07-28 12:55:11 UTC
F25 kernel 4.7.0-0 has also this bug

Comment 4 Knud Christiansen 2016-08-11 18:53:02 UTC

*** This bug has been marked as a duplicate of bug 1359415 ***

Comment 5 Knud Christiansen 2016-09-05 20:44:08 UTC
problem exist also on F25 kernel 4.8.x
Latst test kernel 4.8.0-0.rc2.git3.1.fc25.x86_64

Comment 6 Knud Christiansen 2016-10-01 08:03:37 UTC
No one cares about this bug ?

Is it really a bug in radeon driver or is it in kernel memory mapping ??

[    2.885891] [drm:radeon_get_bios [radeon]] *ERROR* Unable to locate a BIOS ROM
[    2.885952] radeon 0000:01:00.0: Fatal error during GPU init
[    2.886023] [drm] radeon: finishing device.
[    2.886025] [TTM] Memory type 2 has not been initialized
[    2.893413] radeon: probe of 0000:01:00.0 failed with error -22


Knud

Comment 7 Knud Christiansen 2016-10-23 20:46:39 UTC
Seems not be at bug in radeon driver but in Kernel 

https://bugzilla.kernel.org/show_bug.cgi?id=175391

Comment 9 Bjorn Helgaas 2016-10-26 21:38:01 UTC
Appears to be an upstream kernel bug.  There's a test patch at https://bugzilla.kernel.org/show_bug.cgi?id=175391

Comment 10 Knud Christiansen 2016-11-24 16:04:54 UTC
Tested 4.8.10-fc24 KDE spin....works perfect, solves problem

Suggest to close the bug

Br
Knud


Note You need to log in before you can comment on or make changes to this bug.