Bug 135244 - Swap not working
Swap not working
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 06:14 EDT by Geoff Siddell
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-27 07:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Siddell 2004-10-11 06:14:15 EDT
Description of problem: Virtual memory seems to have stopped working
all of a sudden. When I try to open a memory intensive application
such as Gnumeric, Open Office, Printer Configuration or Printing there
 is a pause of several minutes, Open Office never finishes loading.
Also there is a long pause logging in to Gnome but not KDE.


Version-Release number of selected component (if applicable): Kernel
2.6.8-1.521

How reproducible: Log in to Gnome or open a memory intensive app.


Steps to Reproduce:
1.
2.
3.
  
Actual results: Long pauses (5 minutes) or hangs.


Expected results: 20 second pause


Additional info: Problem began right after the box froze at boot time
with an error message "lost interrupt" (if I remember right).
 System monitor shows !00% RAM in use at these times (250 Mb.) but
never any swapping (no disk activity either)
Comment 1 Geoff Siddell 2004-10-12 04:14:13 EDT
Since filing this report I seem to have stumbled on a workaround.
After filing the report I saw that swap was in fact still working but
that there was continuous network activity. On investigating my
network card   settings I discovered that the "Bind to MAC address"
box in "Hardware Device" was ticked, clearing it has solved the problem!
 Still a bug perhaps but not so severe now. What is "Bind to MAC"
anyway?, I dont remember ticking it but it doesn't seem to affect my
home network. 
Comment 2 Dave Jones 2004-10-27 01:36:51 EDT
bind to mac is useful if you have 2 NICs in your machine, and you want to ensure
one of them gets eth0 and the other gets eth1.  I highly doubt its related to
your problem.

There's been no major complaints about swap malfunctioning in FC2, so I'm a bit
curious what exactly you see happening. Can you run 'vmstat 1' and then try to
reproduce this bug ? leave it run for a little while (ie, longer than you think
is an acceptable time to be waiting for the app to load), and then cut-n-paste
the vmstat output into this bug. That will allow us to see what was going on at
the time.
(The output of free, and cat /proc/meminfo whilst its under load will also be
useful)

Thanks.
Comment 3 Geoff Siddell 2004-10-27 06:56:02 EDT
The problem seens to have gone, I can't reproduce it now. If it 
recurs then I will carry out the investigations suggested by Dave 
Jones. I can only suggest that if any one else encounters a similar 
glitch , then try playing with your NIC settings as that seemed to do 
the trick for me.

Note You need to log in before you can comment on or make changes to this bug.