Bug 135257 - Intel 810 on Dell Optiplex GX110
Intel 810 on Dell Optiplex GX110
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 09:14 EDT by Gabe
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 08:58:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gabe 2004-10-11 09:14:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3)
Gecko/20040913 Firefox/0.10

Description of problem:
Intel 810 driver, or version of Xorg, for "RHEL 4 Beta 1 Desktop" will
not correctly start up the Anaconda installer and Xserver at default
resolution through FTP install -- or CDROM install of "RHEL 4 Beta 1
WS" 810 driver will freeze up Xserver, GDM, and GNOME menus after
installation at 1280 by 1024 pixel resolution. This is all on a Dell
OptiPlex GX 110. The monitor is a Dell 1800FP (analog) which should be
60Hz at 1280 by 1024.

Version-Release number of selected component (if applicable):
xorg-6.8.0

How reproducible:
Always

Steps to Reproduce:
1. Use the boot.iso for rhel-4 beta1 Desktop on Dell OptiPlex GX110
2. Choose FTP install
3. Wait for Xserver to start and show static. Freeze.
    

Additional info:

The 810 drivers in RHL 9 and RHEL WS 3 work fine even at 1280 as does
Xfree86.
Comment 5 Gabe 2004-11-04 10:14:49 EST
RHEL 3 WS Update 3 is also affected by this. It seems now to be more 
of an LCD issue with the Dell 1800FP. If I run the setup with the 
monitor turned off it will start X.
Comment 7 Jay Turner 2004-11-12 05:07:38 EST
Removing from the list because it's looking like a monitor problem.
Comment 9 Justin Riley 2005-03-15 00:19:40 EST
This is definitely not a monitor problem.  I've seen a few others on
other forums with this problem and i have the EXACT same problem with
a completely different gateway monitor.  Something is definitely wrong.  
Comment 10 Mike A. Harris 2005-03-15 04:23:54 EST
Everyone having this problem, please attach your X server log file,
config file, and all other details which might assist us in
troubleshooting this problem.
Comment 11 Gabe 2005-04-07 09:09:05 EDT
I don't have the GX110 anymore, its old and passed away. However, I do have an Optiplex GX150 with 
the same monitor and it's working fine with RHEL 4 WS and Fedora 3. It's an NVIDIA video card though. I 
believe the old 110 had an integrated Intel 810.
Comment 12 Mike A. Harris 2005-04-15 07:12:24 EDT
Please supply the information requested in comment #10 if you would like
us to continue tracking this issue.  Once we have the information
requested, we can review it and try to diagnose the problem further.

Thanks in advance.

Setting status to "NEEDINFO" and waiting for requested information to
be attached.
Comment 13 Nathan R Finch 2005-04-25 13:20:10 EDT
I'm having similar problems, I get "lines" running down the screen, I was able
to install FC3 using the 'noprobe' but now X is having the same problem during
normal startup. I'm not an expert, so I'll try to get the log file and post it
(here?). BTW, i have an HP pavilion 6563z that has the integrated Intel 810
video chip, and a 15" CRT that goes with it (an HP S50).
Comment 15 Mike A. Harris 2005-05-12 08:58:59 EDT
The original bug report here was filed against a RHEL4 beta which had
xorg-x11-6.8.0 in it.  RHEL4 shipped with xorg-x11-6.8.1.  Fedora Core 3
also shipped xorg-x11-6.8.1, and we received a fair number of bug reports
about the i810 driver from i810 and i815 users.  Those issues were addressed
and fixed in the 6.8.2 update to Fedora Core 3, and should also be addressed
in the latest 6.8.2 update for RHEL 4.

Since we believe this issue for RHEL4 is resolved in the latest erratum,
and we haven't seen any other bugs reported lately for this hardware,
there's good reason to believe the problem is no longer present, so I'm
closing this bug as "ERRATA" for now.  The original reporter also
indicates in comment #11 that he no longer has the hardware, so we
no longer have someone to test if the issue is fixed for this report.


In response to comment #13:  The problem you are having is the same
issue I mention above in this comment which was present in FC3, but fixed
in FC3 updates.  Update to the latest xorg-x11 with "yum" and the problems
should be gone.

If anyone running RHEL4 still experiences this problem or something
similar to it, make sure you have upgraded to the latest xorg-x11 and
kernel packages released for RHEL4, and make sure you are not running
3rd party kernel modules which invalidate support.  If you can reproduce
the problem(s) with our latest RHEL4 updates, visit the Red Hat Global
Support Services website at http://www.redhat.com/support and log in
and file a support ticket, or call 1-888-RED-HAT1 to talk to a support
associate and receive Red Hat support services.

Thanks.

Setting status to "ERRATA".

Note You need to log in before you can comment on or make changes to this bug.