Bug 135260 - kmodule don't show ide-cd module for cdrom in rc.sysinit
kmodule don't show ide-cd module for cdrom in rc.sysinit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 09:44 EDT by Anton Guda
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: udev-035-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 08:33:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anton Guda 2004-10-11 09:44:27 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux; X11; ru) 
(KHTML, like Gecko) 
 
Description of problem: 
In boot process rc.sysinit uses kmodule to find need-to-load modules. 
I have an IDE CD-writer on secondary master (must to be /dev/hdc). 
kmodule don't show ide-cd module for this device. 
So, module don't loaded, and udev don't create node and symlink for 
it. After loading module by hand, udev creates all needed. 
 
 
Version-Release number of selected component (if applicable): 
initscripts-7.90-1 
udev-034-2 
udzu-1.1.93-1 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1.Connect IDE CDROM(writer) to secondary master. 
2.Need working udev 
3.Boot 
     
Actual Results:  Module don't loaded, so node and symlinks not 
created by udev. 
 
 
Expected Results:  Module must be loaded at boot time. 
 
Additional info: 
 
kmodule uses kudzu library for finding drivers. 
kudzu -p: 
- 
class: CDROM 
bus: IDE 
detached: 0 
device: hdc 
driver: ignore 
desc: "SONY CD-RW CRX195E4 S101 20020425" 
- 
so driver is 'ignore', not 'ide-cd' or some other. 
This may be or a bug in kudzu, of a impossibility 
to figure out driver name without user-supplied info. 
 
Workaround proposition: 
After of before kmodule exec  from initscripts, 
read file like '/etc/sysconfig/kmodules' with 
the same format, as kmodule output, parse it and load modules.
Comment 1 Bill Nottingham 2004-10-11 10:34:15 EDT
udev should be loading it.
Comment 2 Anton Guda 2004-10-11 10:45:51 EDT
udev will be triggerd after module loading. 
It (udev) realy done all things after manual module loading. 
But how udev can figure out the name of driver (and time to load it), 
until its loading?  
Usualy (before udev horror) I had a link cdrom->hdc, 
entry in fstab /cdrom->/dev/cdrom, 
and after command 'mount /cdrom' module loads. 
Now I dont have /dev/hdc, /dev/cdrom until 'modprobe ide-cd'. 
So, kudzu (kmodule) must provide info about needed module 
(may be with user help like /etc/modprobe.conf or so). 
 
Comment 3 Harald Hoyer 2004-10-11 10:50:34 EDT
ide-cd is not a module provided by us... you have a custom kernel..
but really, kudzu should recognize this
Comment 4 Bill Nottingham 2004-10-11 11:37:26 EDT
Hm? This seems to be the same situation as sr_mod/sd_mod and scsi bus
scans... if it's done for scsi, it should be done for IDE as well.
Comment 5 Harald Hoyer 2004-10-11 11:44:31 EDT
hmm... I currently have no simple method to detect that.. there is no
hotplug script and no sysfs information.
Comment 6 Harald Hoyer 2004-10-12 04:22:51 EDT
ok, /proc/ide information is provided
Comment 8 Harald Hoyer 2004-10-12 10:50:18 EDT
please try udev-035-1, as soon as it appears in rawhide
Comment 9 Féliciano Matias 2004-10-14 08:23:46 EDT
Fixed here with udev-035-1.
Comment 10 Anton Guda 2004-10-15 04:12:38 EDT
Confirm: udev-035-1 works fine. 

Note You need to log in before you can comment on or make changes to this bug.