Bug 1352638 - rbdmap map config file is packaged as an executable
Summary: rbdmap map config file is packaged as an executable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Build
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: 2.3
Assignee: Ken Dreyer (Red Hat)
QA Contact: Martin Bukatovic
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-04 13:59 UTC by Martin Bukatovic
Modified: 2017-06-19 13:26 UTC (History)
7 users (show)

Fixed In Version: ceph-10.2.7-2.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-19 13:26:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 17395 None None None 2016-09-23 20:55:24 UTC

Description Martin Bukatovic 2016-07-04 13:59:24 UTC
Description of problem
======================

Ceph configuration file /etc/ceph/rbdmap is packaged with 'x' access right.

Version-Release
===============

ceph-common-10.2.2-5.el7cp.x86_64

How reproducible
================

100 %

Steps to Reproduce
==================

1. Install (or just download) ceph-common package
2. Check access rights of /etc/ceph/rbdmap file

Actual results
==============

Default RBDMAPFILE is executable file:

~~~
# rpm -qlv ceph-common | grep '/etc/ceph/rbdmap'
-rwxr-xr-x    1 root    root                       92 Jun 17 19:18 /etc/ceph/rbdmap
~~~

Expected results
================

Default RBDMAPFILE is not executable file:

~~~
# rpm -qlv ceph-common | grep '/etc/ceph/rbdmap'
-rw-r--r--    1 root    root                       92 Jun 17 19:18 /etc/ceph/rbdmap
~~~

Additional info
===============

Manpage rbdmap(8) states that:

> ... RBDMAPFILE, which defaults to /etc/ceph/rbdmap. This file is expected to
> contain  a  list of RBD images and, possibly, parameters to be passed to the
> underlying rbd command.

In other words: /etc/ceph/rbdmap seems to be a plain config file and there
is no need to flag it as an executable.

Comment 1 Ken Dreyer (Red Hat) 2016-07-05 16:49:24 UTC
This looks cosmetic, retargeting to 2.1

Comment 3 Ken Dreyer (Red Hat) 2017-01-17 03:16:22 UTC
This is low-priority, and missed the v10.2.5 cutoff, so we'll take this in the next rebase from upstream (RH Ceph Storage 2.3)

Comment 5 Ken Dreyer (Red Hat) 2017-04-04 20:43:09 UTC
We will resolve this in RH Ceph Storage 2.3

Comment 11 errata-xmlrpc 2017-06-19 13:26:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.