Bug 135283 - Symbol __VMALLOC_RESERVE will not find by a module
Symbol __VMALLOC_RESERVE will not find by a module
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 14:41 EDT by Jochen Schmitt
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for insert EXPORT_SYMBOL(__VMALLOC_RESERVE) (345 bytes, patch)
2004-10-11 14:43 EDT, Jochen Schmitt
no flags Details | Diff

  None (edit)
Description Jochen Schmitt 2004-10-11 14:41:16 EDT
I have installed kernel 2.6.8-1.603.

When I try to compile a third party kernel module like nvidia, which
include asm/page.h, the resulting module complaints, that the kernel
symbol __VMALLOC_RESERVE didn't exist.

This is coused by a change of asm/page.h. To solve this problem, you a
to insert a EXPORT_SYMBOL(__VMALLOC_RESERVE) to arc/i386/mm/init.c.

Best Regards:

Jochen Schmitt
Comment 1 Jochen Schmitt 2004-10-11 14:43:46 EDT
Created attachment 105021 [details]
Patch for insert EXPORT_SYMBOL(__VMALLOC_RESERVE)

Please add this patch to the kernel RPM for solving the reported bug.
Comment 2 Andrew Farris 2004-10-18 16:35:25 EDT
I highly doubt Redhat will include this patch (well.. I'm certain 
they won't) since the kernel developers have recently chosen to hide 
this symbol deliberately.  The drivers that attempt to poke their 
noses in where they don't belong should be updated, that include the 
nvidia driver.

In the meantime (since this should be resolved duplicate 73733)see 
this link and patch example for the nvidia driver itself (should work 
on any x86 hardware for now).
http://ngc891.blogdns.net/index.php?2004/09/21/3-patched-nvidia-
drivers

--- nv.c.orig   2004-10-18 13:25:45.825785765 -0700
+++ nv.c        2004-10-12 20:53:33.957353480 -0700
@@ -19,6 +19,9 @@
 MODULE_ALIAS_CHARDEV_MAJOR(NV_MAJOR_DEVICE_NUMBER);
 #endif
 
+/* fix for 2.6.9-rc# kernels where __VMALLOC_RESERVE is not exported 
*/
+#define __VMALLOC_RESERVE (128 << 20)
+
 /*
  * our global state; one per device
  */
Comment 3 Pekka Pietikäinen 2004-10-23 07:31:27 EDT

*** This bug has been marked as a duplicate of 73733 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:06:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.