Bug 1352837 (vassal) - Review Request: vassal - Game engine for building and playing online adaptations of board games and card games
Summary: Review Request: vassal - Game engine for building and playing online adaptati...
Status: CLOSED WONTFIX
Alias: vassal
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1132266 (view as bug list)
Depends On:
Blocks: FE-GAMESIG
TreeView+ depends on / blocked
 
Reported: 2016-07-05 08:52 UTC by Igor Gnatenko
Modified: 2018-08-22 07:29 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-08-22 07:29:59 UTC


Attachments (Terms of Use)

Description Igor Gnatenko 2016-07-05 08:52:58 UTC
Spec URL: https://ignatenkobrain.fedorapeople.org/for-review/vassal.spec
SRPM URL: https://ignatenkobrain.fedorapeople.org/for-review/vassal-3.2.16-1.fc25.src.rpm
Description:
Vassal is a game engine for building and playing online adaptations of board
games and card games. Play live on the Internet or by email.
Fedora Account System Username: ignatenkobrain

Comment 1 Igor Gnatenko 2016-07-05 08:53:57 UTC
*** Bug 1132266 has been marked as a duplicate of this bug. ***

Comment 2 Igor Gnatenko 2016-07-05 08:54:45 UTC
Note that not all bundled jars are available in repos. I don't know how properly make Provides: bundled() for them.

Comment 3 jiri vanek 2016-07-22 09:38:58 UTC
(In reply to Igor Gnatenko from comment #2)
> Note that not all bundled jars are available in repos. I don't know how
> properly make Provides: bundled() for them.

As far as I can tell, you cant.
The only proper way is to pack all the bundleds and then build against them. Or not anymore?

Comment 4 Igor Gnatenko 2016-07-22 09:41:32 UTC
(In reply to jiri vanek from comment #3)
> (In reply to Igor Gnatenko from comment #2)
> > Note that not all bundled jars are available in repos. I don't know how
> > properly make Provides: bundled() for them.
> 
> As far as I can tell, you cant.
> The only proper way is to pack all the bundleds and then build against them.
> Or not anymore?
Well, it's still not blocker to have bundled dependencies.

I don't know Java packaging guidelines much (and don't want to), so I just built this package with as much as possible using system libraries.

Comment 5 jiri vanek 2016-07-22 10:49:15 UTC
Unless there was some change in guidelines, it is blocker to pack bundled libraries. I would recommend you to check with java-maint group.

Comment 6 Igor Gnatenko 2016-07-22 10:50:49 UTC
(In reply to jiri vanek from comment #5)
> Unless there was some change in guidelines, it is blocker to pack bundled
> libraries. I would recommend you to check with java-maint group.
Then you didn't read new guidelines, it's allowed for ~3 months already. Probably even more.

Comment 7 Jeremy Newton 2016-11-21 18:34:32 UTC
Hi,

I can take this review if you're interested in review swapping with me

(In reply to Igor Gnatenko from comment #2)
> Note that not all bundled jars are available in repos. I don't know how
> properly make Provides: bundled() for them.

Although the bundling policy is looser now, you still require the "Provides: bundled()" information for anything that you cannot unbundle. This makes it easier to track bundled libraries, such as if the library is introduced into fedora and it can be unbundled, or if a security issue exists and all bundled versions must be patched, etc.

For example if you bundled "foo" with version "1.0.0":

Provides: bundled(foo) = 1.0.0

See the guidelines for details:
https://fedoraproject.org/wiki/Bundled_Libraries?rd=Packaging:Bundled_Libraries

Comment 8 Igor Gnatenko 2016-11-28 08:01:37 UTC
Let's swap.

Comment 9 Jeremy Newton 2016-11-28 14:42:22 UTC
Sounds good, I have the following available:
https://bugzilla.redhat.com/show_bug.cgi?id=1379765

But it doesn't build against rawhide, so I'll have to look into that. Although, we can review this first.

Comment 10 Jeremy Newton 2016-12-05 22:30:44 UTC
Please add the required bundled provides. Let me know if you need assistance. I would think that everything printed by "find lib/ -print" would be bundled.

Let me know if you're still alright with review swapping #1379765

Comment 11 Jeremy Newton 2016-12-11 21:10:46 UTC
If you're still interested, please let me know, I have the following available for swap:

https://bugzilla.redhat.com/show_bug.cgi?id=1403423

I'm just waiting on you to update the specs before I can review this.

Comment 12 Jeremy Newton 2016-12-31 05:34:17 UTC
I don't have any reviews to swap and I no longer have interested in reviewing this. This is up for grabs again.

Comment 13 Ben Rosser 2018-08-07 20:52:02 UTC
Hi Igor,

Somehow I missed this package on my previous pass through the FE-GAMESIG tickets, apologies. :( Are you still interested in it? I can review if so.

Comment 14 Igor Gnatenko 2018-08-22 07:29:59 UTC
Unfortunately I don't have time to work on these review requests anymore, sorry.


Note You need to log in before you can comment on or make changes to this bug.