Bug 1352859 - Hosted engine: Failed to add additional host due to failed to configure management network
Summary: Hosted engine: Failed to add additional host due to failed to configure manag...
Keywords:
Status: CLOSED DUPLICATE of bug 1350763
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine
Version: 3.5.7
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Douglas Schilling Landgraf
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks: 1352452 1354596
TreeView+ depends on / blocked
 
Reported: 2016-07-05 09:48 UTC by cshao
Modified: 2016-07-18 01:05 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-05 15:16:47 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
all log info (1.67 MB, application/x-gzip)
2016-07-05 09:48 UTC, cshao
no flags Details

Description cshao 2016-07-05 09:48:01 UTC
Created attachment 1176336 [details]
all log info

Description of problem:
  Failed to add additional host, it always report "Host hosted_engine_2 installation failed. Failed to configure management network on the host".

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.8-20160630.2.iso
ovirt-node-3.2.3-32.el6.noarch
ovirt-hosted-engine-ha-1.2.10-1.el6ev.noarch
ovirt-hosted-engine-setup-1.2.6.1-1.el6ev.noarch
ovirt-node-plugin-hosted-engine-0.2.0-18.0.el6ev.noarch
ovirt-node-plugin-vdsm-0.2.0-26.el6ev.noarch
rhevm-appliance-20160222.0-1.3.5.ova 


How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H 6.8 on two hosts.
2. Start first host setup with correct steps.
3. After successful deploy first host, start additional host setup with correct steps.

Actual results:
Failed to add additional host, it always report "Host hosted_engine_2 installation failed. Failed to configure management network on the host".

Expected results:
Add additional host can successful.

Additional info:

Comment 1 cshao 2016-07-05 11:41:44 UTC
Add keyword testblocker, due to this bug, we can't test additional host and migrate part cases.

Comment 2 Simone Tiraboschi 2016-07-05 14:44:50 UTC
This is still related to setupHostNetwork but here we have a NullPointerException on engine side.

Caused by: org.ovirt.engine.core.common.errors.VdcBLLException: VdcBLLException: java.lang.NullPointerException (Failed with error ENGINE and code 5001)
	at org.ovirt.engine.core.bll.VdsHandler.handleVdsResult(VdsHandler.java:117) [bll.jar:]
	at org.ovirt.engine.core.bll.VDSBrokerFrontendImpl.RunVdsCommand(VDSBrokerFrontendImpl.java:33) [bll.jar:]
	at org.ovirt.engine.core.bll.network.NetworkConfigurator$1.runInTransaction(NetworkConfigurator.java:140) [bll.jar:]
	at org.ovirt.engine.core.bll.network.NetworkConfigurator$1.runInTransaction(NetworkConfigurator.java:136) [bll.jar:]
	at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInNewTransaction(TransactionSupport.java:210) [utils.jar:]
	at org.ovirt.engine.core.bll.network.NetworkConfigurator.refreshNetworkConfiguration(NetworkConfigurator.java:136) [bll.jar:]
	at org.ovirt.engine.core.bll.InstallVdsInternalCommand.configureManagementNetwork(InstallVdsInternalCommand.java:216) [bll.jar:]
	... 72 more

2016-07-04 05:55:26,156 INFO  [org.ovirt.engine.core.vdsbroker.SetVdsStatusVDSCommand] (org.ovirt.thread.pool-7-thread-19) [5941c545] START, SetVdsStatusVDSCommand(HostName = hosted_engine_2, HostId = d58f6f41-572f-4010-b0dd-7c4c2b29e98e, status=NonOperational, nonOperationalReason=NONE, stopSpmFailureLogged=false), log id: 7d62ecaa
2016-07-04 05:55:26,178 INFO  [org.ovirt.engine.core.vdsbroker.SetVdsStatusVDSCommand] (org.ovirt.thread.pool-7-thread-19) [5941c545] FINISH, SetVdsStatusVDSCommand, log id: 7d62ecaa
2016-07-04 05:55:26,227 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.pool-7-thread-19) [5941c545] Correlation ID: 5941c545, Job ID: 51ac7283-a94b-46bb-8927-cefa7c7dd8db, Call Stack: null, Custom Event ID: -1, Message: Host hosted_engine_2 installation failed. Failed to configure management network on the host.

Comment 3 Simone Tiraboschi 2016-07-05 15:16:47 UTC

*** This bug has been marked as a duplicate of bug 1350763 ***


Note You need to log in before you can comment on or make changes to this bug.