Bug 1352883 - Traceback on adding default automember group and hostgroup set
Summary: Traceback on adding default automember group and hostgroup set
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-05 11:22 UTC by Kaleem
Modified: 2016-11-04 05:56 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:56:12 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Kaleem 2016-07-05 11:22:30 UTC
Description of problem:

[root@dhcp207-129 ipa-automember-cli]# ipa group-add --desc="Default Group" "defgroup"
----------------------
Added group "defgroup"
----------------------
  Group name: defgroup
  Description: Default Group
  GID: 743400079
[root@dhcp207-129 ipa-automember-cli]# ipa automember-default-group-set --type=group --default-group=defgroup
ipa: ERROR: non-public: TypeError: automember_default_group_set.validate_output():
  output['value']: need (<type 'NoneType'>,); got <type 'unicode'>: u'group'
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ipalib/backend.py", line 137, in execute
    result = self.Command[_name](*args, **options)
  File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 447, in __call__
    return self.__do_call(*args, **options)
  File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 486, in __do_call
    self.validate_output(ret, options['version'])
  File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 993, in validate_output
    nice, o.name, o.type, type(value), value)
TypeError: automember_default_group_set.validate_output():
  output['value']: need (<type 'NoneType'>,); got <type 'unicode'>: u'group'
ipa: ERROR: an internal error has occurred
[root@dhcp207-129 ipa-automember-cli]# 

Same for hostgroup set too.

Version-Release number of selected component (if applicable):
[root@dhcp207-129 ipa-automember-cli]# rpm -q ipa-server
ipa-server-4.4.0-1.el7.x86_64
[root@dhcp207-129 ipa-automember-cli]# 

How reproducible:
Always

Steps to Reproduce:
1. See description

Actual results:
Addition of default automember group/hostgroup set failed

Expected results:
Addition of default automember group/hostgroup set should have been successful

Comment 3 Petr Vobornik 2016-07-07 11:53:51 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6037

Comment 4 Jan Cholasta 2016-07-20 11:54:30 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/f0a61546f552d4df887617167f7dc1378cb95083

Comment 6 Kaleem 2016-07-28 10:17:42 UTC
Verified.

[root@dhcp207-129 quickinstall]# ipa group-add --desc="Default Group" "defgroup"
----------------------
Added group "defgroup"
----------------------
  Group name: defgroup
  Description: Default Group
  GID: 1481200001
[root@dhcp207-129 quickinstall]# ipa automember-default-group-set --type=group --default-group=defgroup
---------------------------------------------------
Set default (fallback) group for automember "group"
---------------------------------------------------
  Default (fallback) Group: cn=defgroup,cn=groups,cn=accounts,dc=testrelm,dc=test
[root@dhcp207-129 quickinstall]# 
[root@dhcp207-129 quickinstall]# 
[root@dhcp207-129 quickinstall]# rpm -q ipa-server
ipa-server-4.4.0-3.el7.x86_64
[root@dhcp207-129 quickinstall]#

Comment 8 errata-xmlrpc 2016-11-04 05:56:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.