Bug 1352965 - Infinite recursion in GTK3 clipboard handling
Summary: Infinite recursion in GTK3 clipboard handling
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 24
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1353199 1354122 1354216 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-05 15:27 UTC by Dario Lesca
Modified: 2016-08-08 23:07 UTC (History)
13 users (show)

Fixed In Version: libreoffice-5.1.4.2-5.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-12 15:01:00 UTC


Attachments (Terms of Use)
step to crash (713.08 KB, application/octet-stream)
2016-07-05 16:41 UTC, Dario Lesca
no flags Details

Description Dario Lesca 2016-07-05 15:27:22 UTC
Description of problem:

LibreOffice Calc crash after remove lines

Version-Release number of selected component (if applicable):

5.1.4.2-4.fc24

How reproducible:

Steps to Reproduce:
1. Open Libreoffice Calc
2. do New document
3. Fill some line
4. go a line, right click and select "Remove Line"
5. Line is removed, then libreoffice crash.

Actual results:

With version 5.1.4.2-4.fc24 libreoffice calc crash when I remove a line

Expected results:

Like previous version 5.1.3.2-6.fc24, libreoffice calc NOT must crash when I remove a line

Additional info:

For now (i must work) I have do a "dnf downgrade -y  libreoffice*"

I have also try 'dnf update libreoffice*' for test again the issue and problem has occurred again

then I have downgrade again.

Comment 1 Caolan McNamara 2016-07-05 16:18:02 UTC
Works fine for me.

I enter hello into A1, world into A2. Right click on 1 in the column, full row is selected, right click, delete rows. No crash under X, or wayland. gnome-shell in both cases.

Is this scenario crashing for you ? Or do I need to do something else.

Comment 2 Dario Lesca 2016-07-05 16:41:26 UTC
Created attachment 1176569 [details]
step to crash

Comment 3 Dario Lesca 2016-07-05 16:46:00 UTC
I have reinstall the last version and I have test into new clean user test

The crash it happen anyway

I use Gnome Shell on Xorg

Comment 4 Caolan McNamara 2016-07-05 19:51:36 UTC
Very strange. Exact same thing works fine here. Tried under valgrind with no warnings there either.

When it crashes/quits can you
echo $?
and see what number it gives?

You could try under

LANG=C gdb --args /usr/lib64/libreoffice/program/soffice.bin --calc
(gdb) run

and when it crashes
(gdb) bt
and paste in what output there is.

Comment 5 Dario Lesca 2016-07-05 21:15:41 UTC
[lesca@dodo ~]$ LANG=C gdb --args /usr/lib64/libreoffice/program/soffice.bin --calc
GNU gdb (GDB) Fedora 7.11.1-75.fc24
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/lib64/libreoffice/program/soffice.bin...Reading symbols from /usr/lib64/libreoffice/program/soffice.bin...(no debugging symbols found)...done.
(no debugging symbols found)...done.
Missing separate debuginfos, use: dnf debuginfo-install libreoffice-core-5.1.4.2-4.fc24.x86_64
(gdb) run
Starting program: /usr/lib64/libreoffice/program/soffice.bin --calc
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffdcf91700 (LWP 10862)]
Detaching after fork from child process 10863.
[New Thread 0x7fffd77a5700 (LWP 10864)]
[New Thread 0x7fffd6fa4700 (LWP 10865)]
[New Thread 0x7fffd5b46700 (LWP 10866)]
[New Thread 0x7fffd5345700 (LWP 10867)]
[New Thread 0x7fffc759d700 (LWP 10868)]
[New Thread 0x7fffc6d9c700 (LWP 10869)]
[Thread 0x7fffc759d700 (LWP 10868) exited]
Detaching after fork from child process 10870.
[Thread 0x7fffd77a5700 (LWP 10864) exited]
[New Thread 0x7fffd77a5700 (LWP 10872)]
[New Thread 0x7fffc759d700 (LWP 10873)]
[New Thread 0x7fffac769700 (LWP 10874)]
[Thread 0x7fffac769700 (LWP 10874) exited]
[New Thread 0x7fffac769700 (LWP 10875)]
[Thread 0x7fffd77a5700 (LWP 10872) exited]
[Thread 0x7fffc6d9c700 (LWP 10869) exited]
[New Thread 0x7fffc6d9c700 (LWP 10876)]
[New Thread 0x7fffd77a5700 (LWP 10877)]
[Thread 0x7fffd77a5700 (LWP 10877) exited]
[New Thread 0x7fffd77a5700 (LWP 10878)]
[Thread 0x7fffc6d9c700 (LWP 10876) exited]

** (soffice:10858): WARNING **: Unknown event notification 36
[Thread 0x7fffd77a5700 (LWP 10878) exited]

** (soffice:10858): WARNING **: Unknown event notification 36

** (soffice:10858): WARNING **: Unknown event notification 37
[New Thread 0x7fffd77a5700 (LWP 10879)]

** (soffice:10858): WARNING **: Unknown event notification 36

** (soffice:10858): WARNING **: Unknown event notification 37
[Thread 0x7fffd77a5700 (LWP 10879) exited]

** (soffice:10858): WARNING **: Unknown event notification 34

Thread 1 "soffice.bin" received signal SIGSEGV, Segmentation fault.
0x00007fffebcb3019 in g_type_class_ref () from /lib64/libgobject-2.0.so.0
(gdb) bt
#0  0x00007fffebcb3019 in g_type_class_ref () at /lib64/libgobject-2.0.so.0
(gdb) quit
A debugging session is active.

	Inferior 1 [process 10858] will be killed.

Quit anyway? (y or n) y
[lesca@dodo ~]$

Comment 6 Dario Lesca 2016-07-05 21:26:09 UTC
[lesca@dodo ~]$ LANG=C /usr/lib64/libreoffice/program/soffice.bin --calc

** (soffice:12174): WARNING **: Unknown event notification 36

** (soffice:12174): WARNING **: Unknown event notification 36

** (soffice:12174): WARNING **: Unknown event notification 37
Segmentation fault (core dump creato)
[lesca@dodo ~]$ echo $?
139

NOTE:

My notebook is always update since f18 via fedup and now dnf 

I have try on a new f24 fresh installed + updates and the same thing works fine

Comment 7 Caolan McNamara 2016-07-06 07:27:04 UTC
No symbols in the gdb backtrace. Can you try again but do
dnf debuginfo-install libreoffice-core-5.1.4.2-4.fc24.x86_64
beforehand.

Maybe there is an out of date .so left somewhere because of some failed update over the upgrades

Comment 8 Marco Guazzone 2016-07-06 07:50:48 UTC
I also have problems with the last Libreoffice.
Not only after removing lines, also when editing.
Essentially, it is unusable.
I don't know if the problem has been already reported.
When libreoffice crashes, a popup appears telling me that the problem has been automatically reported.

My system is:
- Lbreoffice 5.1.4.2-4.fc24.x86_64
- XFCE

Comment 9 Marco Guazzone 2016-07-06 08:00:34 UTC
Addendum: in my case it seems crashes happen non-deterministically.
Last time Libreoffice crashes was during an undo operation.
Another time, just while copying some text in the cells.
...

Unfortunately I have not enough space to install debuginfo rpms (they require 5.6 GB)

Comment 10 Dario Lesca 2016-07-06 14:40:37 UTC
I have released 5Gb of space, install debuginfo and rerun gdb:

[lesca@dodo ~]$ 
[lesca@dodo ~]$ LANG=C gdb --args /usr/lib64/libreoffice/program/soffice.bin --calc
GNU gdb (GDB) Fedora 7.11.1-75.fc24
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/lib64/libreoffice/program/soffice.bin...Reading symbols from /usr/lib/debug/usr/lib64/libreoffice/program/soffice.bin.debug...done.
done.
(gdb) run
Starting program: /usr/lib64/libreoffice/program/soffice.bin --calc
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffdcf91700 (LWP 32644)]
Detaching after fork from child process 32647.
[New Thread 0x7fffd77b5700 (LWP 32648)]
[New Thread 0x7fffd6fb4700 (LWP 32649)]
[New Thread 0x7fffd5b56700 (LWP 32650)]
[New Thread 0x7fffd5355700 (LWP 32651)]
[New Thread 0x7fffc759d700 (LWP 32652)]
[New Thread 0x7fffc6d9c700 (LWP 32653)]
[Thread 0x7fffc6d9c700 (LWP 32653) exited]
Detaching after fork from child process 32654.
[Thread 0x7fffd77b5700 (LWP 32648) exited]
[New Thread 0x7fffd77b5700 (LWP 32657)]
[New Thread 0x7fffc6d9c700 (LWP 32658)]
[New Thread 0x7fffa8763700 (LWP 32659)]
[Thread 0x7fffa8763700 (LWP 32659) exited]
[Thread 0x7fffd77b5700 (LWP 32657) exited]
[New Thread 0x7fffd77b5700 (LWP 32660)]
[Thread 0x7fffd77b5700 (LWP 32660) exited]
[New Thread 0x7fffd77b5700 (LWP 32662)]
[Thread 0x7fffd77b5700 (LWP 32662) exited]
[New Thread 0x7fffd77b5700 (LWP 32663)]
[Thread 0x7fffd77b5700 (LWP 32663) exited]
[New Thread 0x7fffd77b5700 (LWP 32666)]
[New Thread 0x7fffa8763700 (LWP 32667)]
[Thread 0x7fffa8763700 (LWP 32667) exited]
[Thread 0x7fffd77b5700 (LWP 32666) exited]

** (soffice:32640): WARNING **: Unknown event notification 36
[New Thread 0x7fffd77b5700 (LWP 32668)]

** (soffice:32640): WARNING **: Unknown event notification 36

** (soffice:32640): WARNING **: Unknown event notification 37
[Thread 0x7fffd77b5700 (LWP 32668) exited]
[Thread 0x7fffc759d700 (LWP 32652) exited]

Thread 1 "soffice.bin" received signal SIGSEGV, Segmentation fault.
0x00007fffebcb3019 in g_type_class_ref (type=type@entry=93825005854240) at gtype.c:2915
2915	{
(gdb) exit
Undefined command: "exit".  Try "help".
(gdb) quit
A debugging session is active.

	Inferior 1 [process 32640] will be killed.

Quit anyway? (y or n) y
[lesca@dodo ~]$ 

Hope this help.

Comment 11 Caolan McNamara 2016-07-06 15:16:25 UTC
you have to enter bt into gdb, e.g.
(gdb) bt
to get the full backtrace

Comment 12 Dario Lesca 2016-07-06 15:51:41 UTC
(gdb) bt
#0  0x00007fffebcb3019 in g_type_class_ref (type=type@entry=93825005854240) at gtype.c:2915
#1  0x00007fffebcb6798 in g_type_create_instance (type=93825005854240) at gtype.c:1821
#2  0x00007fffebc986ab in g_object_new_internal (class=class@entry=0x55555625a7b0, params=params@entry=0x0, n_params=n_params@entry=0)
    at gobject.c:1781
#3  0x00007fffebc9a0cd in g_object_newv (object_type=object_type@entry=93825005854240, n_parameters=n_parameters@entry=0, parameters=parameters@entry=0x0) at gobject.c:1928
#4  0x00007fffebc9a8b4 in g_object_new (object_type=93825005854240, first_property_name=first_property_name@entry=0x0) at gobject.c:1621
#5  0x00007fffdb758ef3 in _gdk_display_create_window (display=display@entry=0x555556253020 [GdkX11Display]) at gdkdisplay.c:2190
#6  0x00007fffdb76dac5 in gdk_window_new (parent=parent@entry=0x55555625c000 [GdkX11Window], attributes=attributes@entry=0x7fffff7ff3d0, attributes_mask=attributes_mask@entry=140) at gdkwindow.c:1317
#7  0x00007fffdbc0430b in gtk_invisible_realize (widget=0x555559b2a570 [GtkInvisible]) at gtkinvisible.c:254
#8  0x00007fffebc93617 in _g_closure_invoke_va (closure=closure@entry=0x555556270820, return_value=return_value@entry=0x0, instance=instance@entry=0x555559b2a570, args=args@entry=0x7fffff7ff670, n_params=<optimized out>, param_types=0x0) at gclosure.c:867
#9  0x00007fffebcadea9 in g_signal_emit_valist (instance=0x555559b2a570, signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7fffff7ff670)
    at gsignal.c:3294
#10 0x00007fffebcae4ff in g_signal_emit (instance=instance@entry=0x555559b2a570, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3441
#11 0x00007fffdbd723be in gtk_widget_realize (widget=0x555559b2a570 [GtkInvisible]) at gtkwidget.c:5453
#12 0x00007fffebc98c29 in g_object_new_internal (class=class@entry=0x555557c4d370, params=params@entry=0x7fffff7ff940, n_params=n_params@entry=1)
    at gobject.c:1821
#13 0x00007fffebc9a5ee in g_object_new_valist (object_type=object_type@entry=93825033097808, first_property_name=first_property_name@entry=0x7fffdbdf6575 "screen", var_args=var_args@entry=0x7fffff7ffa90) at gobject.c:2040
#14 0x00007fffebc9a8a1 in g_object_new (object_type=93825033097808, first_property_name=first_property_name@entry=0x7fffdbdf6575 "screen")
    at gobject.c:1624
#15 0x00007fffdbc044ec in gtk_invisible_new_for_screen (screen=<optimized out>) at gtkinvisible.c:152
#16 0x00007fffdbd8b8be in gtk_clipboard_real_request_contents (provider=0, display=<optimized out>) at gtkclipboard.c:436
#17 0x00007fffdbd8b8be in gtk_clipboard_real_request_contents (clipboard=0x5555563b6390 [GtkClipboard], target=0x46, callback=0x7fffdbd8bf40 <request_text_received_func>, user_data=0x555559b321d0) at gtkclipboard.c:1013
#18 0x00007fffdbd8c5d8 in gtk_clipboard_wait_for_text (clipboard=clipboard@entry=0x5555563b6390 [GtkClipboard]) at gtkclipboard.c:1475
#19 0x00007fffdc3252f3 in GtkClipboardTransferable::getTransferData(com::sun::star::datatransfer::DataFlavor const&) (this=0x7fffd7dc9cc8, rFlavor=...) at /usr/src/debug/libreoffice-5.1.4.2/vcl/unx/gtk3/gtk3gtkinst.cxx:193
#20 0x00007fffdc31fec8 in VclToGtkHelper::setSelectionData(com::sun::star::uno::Reference<com::sun::star::datatransfer::XTransferable> const&, _GtkSelectionData*, unsigned int) (this=<optimized out>, rTrans=..., selection_data=0x7fffff800330, info=<optimized out>)
    at /usr/src/debug/libreoffice-5.1.4.2/vcl/unx/gtk3/gtk3gtkinst.cxx:470
#24 0x00007fffebcae9ab in <emit signal 0x7fffdbe070c3 "selection-get" on instance 0x555556555330 [GtkInvisible]> (instance=instance@entry=0x5555565553---Type <return> to continue, or q <return> to quit---
30, detailed_signal=detailed_signal@entry=0x7fffdbe070c3 "selection-get") at gsignal.c:3481
    #21 0x00007fffebc9333f in g_closure_invoke (closure=0x555557c4b4c0, return_value=return_value@entry=0x0, n_param_values=4, param_values=param_values@entry=0x7fffff7fff50, invocation_hint=invocation_hint@entry=0x7fffff7ffed0) at gclosure.c:804
    #22 0x00007fffebca54a2 in signal_emit_unlocked_R (node=node@entry=0x5555562611c0, detail=detail@entry=0, instance=instance@entry=0x555556555330, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fffff7fff50) at gsignal.c:3629
    #23 0x00007fffebcae12d in g_signal_emit_valist (instance=instance@entry=0x555556555330, signal_id=signal_id@entry=75, detail=detail@entry=0, var_args=var_args@entry=0x7fffff800198) at gsignal.c:3385
#25 0x00007fffdbcaa40b in gtk_selection_invoke_handler (widget=0x555556555330 [GtkInvisible], data=0x7fffff800330, time=35205809)
    at gtkselection.c:3067
#26 0x00007fffdbcaa6df in gtk_selection_convert (widget=0x555559b2a450 [GtkInvisible], selection=0x1, target=0x46, time_=35205809)
    at gtkselection.c:1139
#27 0x00007fffdbd8c5d8 in gtk_clipboard_wait_for_text (clipboard=clipboard@entry=0x5555563b6390 [GtkClipboard]) at gtkclipboard.c:1475
#28 0x00007fffdc3252f3 in GtkClipboardTransferable::getTransferData(com::sun::star::datatransfer::DataFlavor const&) (this=0x7fffd7dc9cc8, rFlavor=...) at /usr/src/debug/libreoffice-5.1.4.2/vcl/unx/gtk3/gtk3gtkinst.cxx:193
#29 0x00007fffdc31fec8 in VclToGtkHelper::setSelectionData(com::sun::star::uno::Reference<com::sun::star::datatransfer::XTransferable> const&, _GtkSelectionData*, unsigned int) (this=<optimized out>, rTrans=..., selection_data=0x7fffff800b30, info=<optimized out>)
    at /usr/src/debug/libreoffice-5.1.4.2/vcl/unx/gtk3/gtk3gtkinst.cxx:470
#33 0x00007fffebcae9ab in <emit signal 0x7fffdbe070c3 "selection-get" on instance 0x555556555330 [GtkInvisible]> (instance=instance@entry=0x555556555330, detailed_signal=detailed_signal@entry=0x7fffdbe070c3 "selection-get") at gsignal.c:3481
    #30 0x00007fffebc9333f in g_closure_invoke (closure=0x555557c4b4c0, return_value=return_value@entry=0x0, n_param_values=4, param_values=param_values@entry=0x7fffff800750, invocation_hint=invocation_hint@entry=0x7fffff8006d0) at gclosure.c:804
    #31 0x00007fffebca54a2 in signal_emit_unlocked_R (node=node@entry=0x5555562611c0, detail=detail@entry=0, instance=instance@entry=0x555556555330, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fffff800750) at gsignal.c:3629
    #32 0x00007fffebcae12d in g_signal_emit_valist (instance=instance@entry=0x555556555330, signal_id=signal_id@entry=75, detail=detail@entry=0, var_args=var_args@entry=0x7fffff800998) at gsignal.c:3385
#34 0x00007fffdbcaa40b in gtk_selection_invoke_handler (widget=0x555556555330 [GtkInvisible], data=0x7fffff800b30, time=35205809)
    at gtkselection.c:3067
#35 0x00007fffdbcaa6df in gtk_selection_convert (widget=0x555559b2a330 [GtkInvisible], selection=0x1, target=0x46, time_=35205809)
    at gtkselection.c:1139
#36 0x00007fffdbd8c5d8 in gtk_clipboard_wait_for_text (clipboard=clipboard@entry=0x5555563b6390 [GtkClipboard]) at gtkclipboard.c:1475
#37 0x00007fffdc3252f3 in GtkClipboardTransferable::getTransferData(com::sun::star::datatransfer::DataFlavor const&) (this=0x7fffd7dc9cc8, rFlavor=...) at /usr/src/debug/libreoffice-5.1.4.2/vcl/unx/gtk3/gtk3gtkinst.cxx:193
#38 0x00007fffdc31fec8 in VclToGtkHelper::setSelectionData(com::sun::star::uno::Reference<com::sun::star::datatransfer::XTransferable> const&, _GtkSelectionData*, unsigned int) (this=<optimized out>, rTrans=..., selection_data=0x7fffff801330, info=<optimized out>)
---Type <return> to continue, or q <return> to quit---
    at /usr/src/debug/libreoffice-5.1.4.2/vcl/unx/gtk3/gtk3gtkinst.cxx:470
#42 0x00007fffebcae9ab in <emit signal 0x7fffdbe070c3 "selection-get" on instance 0x555556555330 [GtkInvisible]> (instance=instance@entry=0x555556555330, detailed_signal=detailed_signal@entry=0x7fffdbe070c3 "selection-get") at gsignal.c:3481
    #39 0x00007fffebc9333f in g_closure_invoke (closure=0x555557c4b4c0, return_value=return_value@entry=0x0, n_param_values=4, param_values=param_values@entry=0x7fffff800f50, invocation_hint=invocation_hint@entry=0x7fffff800ed0) at gclosure.c:804
    #40 0x00007fffebca54a2 in signal_emit_unlocked_R (node=node@entry=0x5555562611c0, detail=detail@entry=0, instance=instance@entry=0x555556555330, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fffff800f50) at gsignal.c:3629
    #41 0x00007fffebcae12d in g_signal_emit_valist (instance=instance@entry=0x555556555330, signal_id=signal_id@entry=75, detail=detail@entry=0, var_args=var_args@entry=0x7fffff801198) at gsignal.c:3385
#43 0x00007fffdbcaa40b in gtk_selection_invoke_handler (widget=0x555556555330 [GtkInvisible], data=0x7fffff801330, time=35205809)
    at gtkselection.c:3067
#44 0x00007fffdbcaa6df in gtk_selection_convert (widget=0x555559b2a210 [GtkInvisible], selection=0x1, target=0x46, time_=35205809)
    at gtkselection.c:1139
#45 0x00007fffdbd8c5d8 in gtk_clipboard_wait_for_text (clipboard=clipboard@entry=0x5555563b6390 [GtkClipboard]) at gtkclipboard.c:1475
#46 0x00007fffdc3252f3 in GtkClipboardTransferable::getTransferData(com::sun::star::datatransfer::DataFlavor const&) (this=0x7fffd7dc9cc8, rFlavor=...) at /usr/src/debug/libreoffice-5.1.4.2/vcl/unx/gtk3/gtk3gtkinst.cxx:193
#47 0x00007fffdc31fec8 in VclToGtkHelper::setSelectionData(com::sun::star::uno::Reference<com::sun::star::datatransfer::XTransferable> const&, _GtkSelectionData*, unsigned int) (this=<optimized out>, rTrans=..., selection_data=0x7fffff801b30, info=<optimized out>)
    at /usr/src/debug/libreoffice-5.1.4.2/vcl/unx/gtk3/gtk3gtkinst.cxx:470
#51 0x00007fffebcae9ab in <emit signal 0x7fffdbe070c3 "selection-get" on instance 0x555556555330 [GtkInvisible]> (instance=instance@entry=0x555556555330, detailed_signal=detailed_signal@entry=0x7fffdbe070c3 "selection-get") at gsignal.c:3481
    #48 0x00007fffebc9333f in g_closure_invoke (closure=0x555557c4b4c0, return_value=return_value@entry=0x0, n_param_values=4, param_values=param_values@entry=0x7fffff801750, invocation_hint=invocation_hint@entry=0x7fffff8016d0) at gclosure.c:804
    #49 0x00007fffebca54a2 in signal_emit_unlocked_R (node=node@entry=0x5555562611c0, detail=detail@entry=0, instance=instance@entry=0x555556555330, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fffff801750) at gsignal.c:3629
    #50 0x00007fffebcae12d in g_signal_emit_valist (instance=instance@entry=0x555556555330, signal_id=signal_id@entry=75, detail=detail@entry=0, var_args=var_args@entry=0x7fffff801998) at gsignal.c:3385
#52 0x00007fffdbcaa40b in gtk_selection_invoke_handler (widget=0x555556555330 [GtkInvisible], data=0x7fffff801b30, time=35205809)
    at gtkselection.c:3067
#53 0x00007fffdbcaa6df in gtk_selection_convert (widget=0x555559b2a0f0 [GtkInvisible], selection=0x1, target=0x46, time_=35205809)
    at gtkselection.c:1139
#54 0x00007fffdbd8c5d8 in gtk_clipboard_wait_for_text (clipboard=clipboard@entry=0x5555563b6390 [GtkClipboard]) at gtkclipboard.c:1475
#55 0x00007fffdc3252f3 in GtkClipboardTransferable::getTransferData(com::sun::star::datatransfer::DataFlavor const&) (this=0x7fffd7dc9cc8, rFlavor=...) at /usr/src/debug/libreoffice-5.1.4.2/vcl/unx/gtk3/gtk3gtkinst.cxx:193
---Type <return> to continue, or q <return> to quit---

I have press two time <enter> copy and paste here... I must do some other thing?

Comment 13 Michael Stahl 2016-07-06 19:09:16 UTC
it looks like some funky recursion in the gtk clipboard

iirc i saw something like this last week but forgot about it,
i have "clipit" running which is some multi-clipboard tool,
that tends to interfere with things by triggering clipboard
operations at inopportune times.

do you also have something like clipit, parcellite or klipper running?

Comment 14 Caolan McNamara 2016-07-06 19:41:16 UTC
*** Bug 1353199 has been marked as a duplicate of this bug. ***

Comment 15 Dario Lesca 2016-07-06 23:34:44 UTC
>> do you also have something like clipit, parcellite or klipper running?
Yes, I have running clipit.
If I close it, libreoffice calc work fine.

I have also try to install and run clipit on a working system.
After I run clipit libreoffice have the same problem: crash if I delete a row.

Comment 16 Caolan McNamara 2016-07-07 12:54:53 UTC
yeah, that's the one. I can reproduce now

Comment 17 Fedora Update System 2016-07-09 14:39:06 UTC
libreoffice-5.1.4.2-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-983ce3851d

Comment 18 Caolan McNamara 2016-07-09 19:36:18 UTC
*** Bug 1354122 has been marked as a duplicate of this bug. ***

Comment 19 Fedora Update System 2016-07-10 15:57:30 UTC
libreoffice-5.1.4.2-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-983ce3851d

Comment 20 Caolan McNamara 2016-07-11 07:09:28 UTC
*** Bug 1354216 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2016-07-12 15:00:40 UTC
libreoffice-5.1.4.2-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Mike Silberg 2016-07-28 09:26:59 UTC
I'm using Fedora 24 64 bit. When I'm working with Libreoffice Calc (5.1.5.1-2.fc24) and trying to copy paste cells content the first thing that happens is a jump of CPU load and then after a few second an office itself crashes.

When I check my logs I see this error report:
"libreoffice quit unexpectedly: soffice.bin killed by SIGSEGV".


Note You need to log in before you can comment on or make changes to this bug.