Bug 1353070 - Migration is failed from host RHEL7.2.z to host RHEL7.3 with "-M rhel6.6.0 -device e1000-82540em"
Summary: Migration is failed from host RHEL7.2.z to host RHEL7.3 with "-M rhel6.6.0 -d...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Dr. David Alan Gilbert
QA Contact: huiqingding
URL:
Whiteboard:
Depends On:
Blocks: 1289197
TreeView+ depends on / blocked
 
Reported: 2016-07-06 01:57 UTC by huiqingding
Modified: 2016-11-07 21:21 UTC (History)
6 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-13.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 21:21:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description huiqingding 2016-07-06 01:57:25 UTC
Description of problem:
Migration is failed from host RHEL7.2.z to host RHEL7.3 with "-M rhel6.6.0 -device e1000-82540em"

Version-Release number of selected component (if applicable):

Host RHEL7.2.z:
kernel-3.10.0-327.28.2.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.16.x86_64

Host RHEL7.3:
kernel-3.10.0-445.el7.x86_64
qemu-kvm-rhev-2.6.0-11.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot vm on src host RHEL7.2.z:
#  /usr/libexec/qemu-kvm -cpu SandyBridge -M rhel6.6.0 -netdev tap,id=hostnet3,vhost=on,script=/etc/qemu-ifup -device e1000-82540em,netdev=hostnet3,id=virtio-net-pci3,mac=4e:63:28:bc:c1:35,bus=pci.0,addr=0x1e,multifunction=off -monitor stdio
2.  boot vm on dst host RHEL7.3:
#  /usr/libexec/qemu-kvm -cpu SandyBridge -M rhel6.6.0 -netdev tap,id=hostnet3,vhost=on,script=/etc/qemu-ifup -device e1000-82540em,netdev=hostnet3,id=virtio-net-pci3,mac=4e:63:28:bc:c1:35,bus=pci.0,addr=0x1e,multifunction=off -monitor stdio -incoming tcp:0:5800
3. do migration from src host to dst host
(qemu) migrate -d tcp:{dst_ip}:5800

Actual results:
qemu-kvm of dst host quits with error:
qemu-kvm: Length mismatch: 0000:00:1e.0/e1000.rom: 0x40000 in != 0x20000: Invalid argument
qemu-kvm: error while loading state for instance 0x0 of device 'ram'
copying E and F segments from pc.bios to pc.ram
copying C and D segments from pc.rom to pc.ram
qemu-kvm: load of migration failed: Invalid argument

Expected results:
Migration can be finished normally.

Additional info:

Comment 2 Dr. David Alan Gilbert 2016-07-06 09:33:03 UTC
OK, this needs fixing; I need to think about the best way.

rhel6 has the e1000 device
rhel7.x.x have both e1000 and e1000-82540em
     e1000-82540em is exactly the same as e1000 

in rhel 7.2.x e1000 is a subclass of e1000-82540em
in rhel 7.3.x e1000-82540em is an alias of e1000

in 7.x.x We've got a compat rule that says for rhel6.6.0 to use the RHEL6 ROM for e1000
In 7.2.x because e1000-82540em is a separate device class it doesn't use this rule, so e1000-82540em uses the rhel7 rom, while e1000 uses rhel6 rom
In 7.3.x because it's actually an alias, both devices hit the rule and so both use the rhel6 rom.

Could this affect a real customer?   Since rhel6 doesn't have e1000-82540em they'd haver hit it purely on a machine created on rhel6; however if they created a VM on rhel6, and kept that machine description and added a new net interface then they could hit it, so yes it needs fixing.

Comment 3 Dr. David Alan Gilbert 2016-07-06 11:09:36 UTC
fix posted to list.

Comment 4 Miroslav Rezanina 2016-07-12 08:49:13 UTC
Fix included in qemu-kvm-rhev-2.6.0-13.el7

Comment 6 huiqingding 2016-08-25 08:59:08 UTC
Reproduce this bug using the version:
RHEL7.2.z host:
kernel-3.10.0-327.37.1.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.21.x86_64
RHEL7.3 host:
kernel-3.10.0-493.el7.x86_64
qemu-kvm-rhev-2.6.0-18.el7.x86_64

Steps to Reproduce:
1. boot vm on src host RHEL7.2.z:
#  /usr/libexec/qemu-kvm -cpu SandyBridge -M rhel6.6.0 -netdev tap,id=hostnet3,vhost=on,script=/etc/qemu-ifup -device e1000-82540em,netdev=hostnet3,id=virtio-net-pci3,mac=4e:63:28:bc:c1:35,bus=pci.0,addr=0x1e,multifunction=off -monitor stdio
2.  boot vm on dst host RHEL7.3:
#  /usr/libexec/qemu-kvm -cpu SandyBridge -M rhel6.6.0 -netdev tap,id=hostnet3,vhost=on,script=/etc/qemu-ifup -device e1000-82540em,netdev=hostnet3,id=virtio-net-pci3,mac=4e:63:28:bc:c1:35,bus=pci.0,addr=0x1e,multifunction=off -monitor stdio -incoming tcp:0:5800
3. do migration from src host to dst host
(qemu) migrate -d tcp:{dst_ip}:5800

Actual results:
qemu-kvm of dst host quits with error:
qemu-kvm: Length mismatch: 0000:00:1e.0/e1000.rom: 0x40000 in != 0x20000: Invalid argument
qemu-kvm: error while loading state for instance 0x0 of device 'ram'
copying E and F segments from pc.bios to pc.ram
copying C and D segments from pc.rom to pc.ram
qemu-kvm: load of migration failed: Invalid argument

Verify this bug using the version:
RHEL7.2.z host:
kernel-3.10.0-327.37.1.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.21.x86_64
RHEL7.3 host:
kernel-3.10.0-493.el7.x86_64
qemu-kvm-rhev-2.6.0-21.el7.x86_64

Test the above steps, migration can be finished normally.

Comment 7 huiqingding 2016-09-08 10:24:58 UTC
Based on comment #6, set this bug to be verified.

Comment 9 errata-xmlrpc 2016-11-07 21:21:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.