Bug 1353072 - ipa unknown command vault-add
Summary: ipa unknown command vault-add
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression, TestBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-06 02:08 UTC by Scott Poore
Modified: 2016-11-04 05:56 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:56:20 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Scott Poore 2016-07-06 02:08:14 UTC
Description of problem:

The vault-add command seems to be missing:

[root@master ~]# ipa vault-add
ipa: ERROR: unknown command 'vault-add'


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64


How reproducible:
always

Steps to Reproduce:
1.  ipa-server-install
2.  ipa-kra-install
3.  ipa vault-add

Actual results:
unknown command error.

Expected results:
add vault without error

Additional info:

I see no vault_add entries in /var/log/httpd/error_log.

Comment 3 Petr Vobornik 2016-07-07 11:42:10 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6035

Comment 5 Petr Vobornik 2016-07-12 14:06:31 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6047

Comment 6 Petr Vobornik 2016-07-13 16:47:48 UTC
Second part fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/a1a7ecdc7bf6686adf8558cedd3964f9e4805469

Comment 8 Scott Poore 2016-07-15 14:28:21 UTC
Verified.

Version ::

ipa-server-4.4.0-2.1.el7.x86_64

Results ::

[root@rhel7-1 ~]# ipa-kra-install
Directory Manager password: 


===================================================================
This program will setup Dogtag KRA for the IPA Server.


Configuring KRA server (pki-tomcatd). Estimated time: 2 minutes 6 seconds
  [1/8]: configuring KRA instance
  [2/8]: create KRA agent
  [3/8]: restarting KRA
  [4/8]: configure certmonger for renewals
  [5/8]: configure certificate renewals
  [6/8]: configure HTTP to proxy connections
  [7/8]: add vault container
  [8/8]: apply LDAP updates
Done configuring KRA server (pki-tomcatd).
Restarting the directory server
The ipa-kra-install command was successful

[root@rhel7-1 ~]# ipa vault-add 
Vault name: test
New password: 
Verify password: 
------------------
Added vault "test"
------------------

Comment 10 errata-xmlrpc 2016-11-04 05:56:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.