Bug 135315 - OpenIPMI libraries need IPMB mutex
OpenIPMI libraries need IPMB mutex
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: distribution (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: dff
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 17:23 EDT by Matt Domsch
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 01:27:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2004-10-11 17:23:32 EDT
Description of problem:
The OpenIPMI userspace libraries, version 1.4.3 and below, do not 
mutually exclude multiple userspace applications from issuing 
commands which utilize the IPMB protocol.  IPMB, a very simple 3-wire 
I2C bus protocol, has very slow device semantics: commands are not 
sent atomically; the command sender must wait until the device 
responds; the sender must look at the sequence number of commands 
that finish and determine who sent them, to pass the response back to 
the proper caller.  The libraries do not do this today; it is simple 
for multiple IPMI library-using applications to confuse themselves 
and other apps because this coordination does not occur.

Chris Poblete from Dell is speaking with the OpenIPMI maintainer, 
Corey Minyard, about the proper way to solve this.  Patches will be 
forthcoming, and will be worked through Corey as the upstream 
maintainer.

Dell will need Red Hat to include a future version of the OpenIPMI 
userspace libraries which address this.
Comment 3 Matt Domsch 2004-12-10 01:27:15 EST
Per Chris Poblete in conversation with Corey Minyard, the OpenIPMI
driver already does this coordination.  Closing.

Note You need to log in before you can comment on or make changes to this bug.