Bug 1353158 - Welcome to Red Hat Enterprise Linux Client 7.2 (Maipo)! in RHVH boot screen
Summary: Welcome to Red Hat Enterprise Linux Client 7.2 (Maipo)! in RHVH boot screen
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor-ng
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.0.2
: 4.0.0
Assignee: Ryan Barry
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-06 10:19 UTC by Ying Cui
Modified: 2016-08-23 21:07 UTC (History)
8 users (show)

Fixed In Version: redhat-virtualization-host-productimg-4.0-0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:07:55 UTC
oVirt Team: Node


Attachments (Terms of Use)
screen_output (486.49 KB, text/plain)
2016-07-06 10:48 UTC, Ying Cui
no flags Details
RHVH-7.2-20160718.1 new screen output (460.22 KB, text/plain)
2016-08-01 10:11 UTC, Ying Cui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1702 normal SHIPPED_LIVE redhat-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:35:27 UTC

Description Ying Cui 2016-07-06 10:19:21 UTC
Description:
Boot RHVH ISO to install RHVH, during booting process, the screen output show "Welcome to Red Hat Enterprise Linux Client 7.2 (Maipo)"


<snip>
[  OK  ] Started Plymouth switch root service.
         Starting Switch Root...

Welcome to Red Hat Enterprise Linux Client 7.2 (Maipo)!

[  OK  ] Stopped Switch Root.
[  OK  ] Created slice User and Session Slice.
[  OK  ] Listening on udev Control Socket.
</snip>

Version-Release number of selected component (if applicable):
RHEV-H-7.2-20160701.2-RHVH-x86_64-dvd1.iso

How reproducible:
always

Steps to Reproduce:
1. Boot the RHVH _ISO_

Actual Result:
"Welcome to Red Hat Enterprise Linux Client 7.2 (Maipo)" is in screen output.
It confuse the users what version they are running.

Expected Result:
Should show "Welcome to Red Hat Virtualization Host ..."

Comment 1 Ying Cui 2016-07-06 10:48:42 UTC
Created attachment 1176837 [details]
screen_output

Comment 2 Ryan Barry 2016-07-07 14:41:07 UTC
This may be extraordinarily difficult to fix, as we don't control the process.

systemd pulls this out of PRETTY_NAME in /etc/os-release

On the ISO, this is still using information from redhat-release, since rhev-hypervisor7-ng-image is included in /Packages.

We can't easily include redhat-release-rhev-hypervisor, as we're using this to track all the RHV/platform dependencies instead of doing it in a kickstart (like legacy).

It's possible to build a dummy package for anaconda only which just includes an updated /etc/os-release with the correct PRETTYNAME.

I think Joey should also be able to pull this into the distill and use it instead of redhat-release, but Joey will need to comment on that, since I don't know the details of the distill.

Comment 5 Ryan Barry 2016-07-15 12:37:34 UTC
This hasn't been included in a build yet... Waiting for the next distill

Comment 6 Fabian Deutsch 2016-07-18 14:08:21 UTC
I do see this as a bit risky.
But let's see how this works out, if it works: good.
If it brakes, then we should take this small drawback and keep the usual release file.

Comment 7 Ying Cui 2016-08-01 10:08:48 UTC
Failed test the build RHVH-7.2-20160718.1-RHVH-x86_64-dvd1.iso in Fixed In Version, so I have to assign this bug.

It is not fixed. "Welcome to Red Hat Enterprise Linux Client 7.2 (Maipo)!" is in screen output as well on RHVH-7.2-20160718.1.

Comment 8 Ying Cui 2016-08-01 10:11:08 UTC
Created attachment 1186331 [details]
RHVH-7.2-20160718.1 new screen output

Comment 9 Ryan Barry 2016-08-01 12:27:16 UTC
This fix will come along with the general Anaconda branding in the next build, as they are part of the same package.

Comment 11 Ying Cui 2016-08-11 10:15:46 UTC
VERIFIED on RHVH-7.2-20160804.0-RHVH-x86_64-dvd1.iso, redhat-virtualization-host-productimg-4.0-0.0.el7.x86_64.rpm


Already displayed Welcome to Red Hat Virtualization Host 4.0 (el7.2)!

<snip>

[  OK  ] Stopped Device-Mapper Multipath Device Controller.

[  OK  ] Started Plymouth switch root service.

         Starting Switch Root...



Welcome to Red Hat Virtualization Host 4.0 (el7.2)!



[  OK  ] Stopped Switch Root.

[  OK  ] Reached target Timers.

         Mounting Debug File System...

</snip>

Comment 13 errata-xmlrpc 2016-08-23 21:07:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1702.html


Note You need to log in before you can comment on or make changes to this bug.