Bug 13532 - Unable to execute "make" or "rpm -i" commands
Summary: Unable to execute "make" or "rpm -i" commands
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-06 14:35 UTC by harry.heinisch
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2000-07-06 23:20:14 UTC


Attachments (Terms of Use)

Description harry.heinisch 2000-07-06 14:35:39 UTC
Unable to execute "make" or "rpm -i" commands.  Compilation failed with 
message "Segmentation fault (Core dump)".  The problem occurred after 
rebuilding RedHat 7.0 Beta2 with 2.2.16 standard kernel.
It seems that ksh is not on CD.

Hardware:
Compaq ProLiant DL380 and ML530
Embedded SCSI or Array

Steps to reproduce:
1. Install RedHat 7.0 Beta2
2. patch cciss-099 driver to standard 2.2.16 kernel (not 2.2.16-3)
3. rebuild kernel
4. reboot
5. trying to run IO test but it failed, so tried to install ksh and it 
failed with segmentation fault error.  Then went to /usr/src/linux dir and 
run make menuconfig, it gives same message and stopped.

Comment 1 Glen Foster 2000-07-06 23:20:11 UTC
Problem is isolated to using 2.1.90-17 family of packages for "glibc".  I ran
across this with trying to compile a test suite using those packages and got the
same results.  I then tried the .18 versions with beta2 and make(1) worked
correctly.  I also verified that the 2.1.91-2 family of "glibc" packages in
beta3 works as well.


Note You need to log in before you can comment on or make changes to this bug.