Bug 1353225 - polkit uninstallable in brew
Summary: polkit uninstallable in brew
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: polkit
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miloslav Trmač
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2016-07-06 15:00 UTC by Richard W.M. Jones
Modified: 2016-07-06 15:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-06 15:20:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Richard W.M. Jones 2016-07-06 15:00:43 UTC
Description of problem:

DEBUG util.py:417:  Error: Package: polkit-0.112-8.el7.ppc64le (build)
DEBUG util.py:417:             Requires: libmozjs-17.0.1.so()(64bit)
DEBUG util.py:417:  Error: Package: polkit-0.112-8.el7.ppc64le (build)
DEBUG util.py:417:             Requires: libmozjs-17.0.1.so(mozjs_17.0.1)(64bit)

Full log is here:
http://download.eng.bos.redhat.com/brewroot/work/tasks/4246/11314246/root.log

Version-Release number of selected component (if applicable):

polkit-0.112-8.el7.ppc64le

How reproducible:

100%

Steps to Reproduce:
1. Do any brew build at all which depends on polkit.

Comment 3 Richard W.M. Jones 2016-07-06 15:20:43 UTC
Solution was to tag polkit-0.112-9.el7 into rhel-7.3-temp-override, ie:

brew tag-pkg rhel-7.3-temp-override polkit-0.112-9.el7


Note You need to log in before you can comment on or make changes to this bug.