Bug 1353251 - Node fails to start with error "Could not find an allocated subnet for node: "
Summary: Node fails to start with error "Could not find an allocated subnet for node: "
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Derek Carr
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-06 16:05 UTC by Miheer Salunke
Modified: 2019-11-14 08:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:39:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Comment 1 Miheer Salunke 2016-07-06 16:07:11 UTC
Description of problem:

While installing, the node fails to start with the Could not find an allocated subnet for node:  error. The we after creating the hostsubnet manually (https://access.redhat.com/solutions/2087721), the re-run of installer works but then again fails while registering other node as it seems the master is not allocating the subnet to the node, thereby node registration fails and node service fails to start. 



Version-Release number of selected component (if applicable):
Openshift Enterprise 3.2

How reproducible:
Only at customer end

Steps to Reproduce:
1.Mentioned in the description

OR

1. We made the installation success by adding the host subnet manually and then 
   re-running the installer.
2. Then we removed the hostsubnet and then again tried to restart the node which again failed.




Actual results:
When node starts the master shall allocate the subnet to it

Expected results:
When node starts the master doesn't seem to have allocated the subnet to the node.

Comment 11 Troy Dawson 2016-08-01 22:08:15 UTC
I'm moving this back to assigned.  Please move it back to Modified when the pull requests have merged.  Then once we have merged the code from origin to OSE I will move this to QE.

Comment 12 Andy Goldstein 2016-08-04 16:05:44 UTC
PRs have merged to origin.

Comment 13 Troy Dawson 2016-08-08 21:41:24 UTC
This has been merged and is in OSE v3.3.0.17 or newer.

Comment 15 DeShuai Ma 2016-08-09 04:30:15 UTC
Test on latest openshift env, no this issue, verify this bug.
[root@ip-172-18-0-56 ~]# openshift version
openshift v3.3.0.17
kubernetes v1.3.0+507d3a7
etcd 2.3.0+git

steps:
setup a cluster env, then check all node is ready and no errors in node log 'Could not find an allocated subnet for node'

Comment 17 errata-xmlrpc 2016-09-27 09:39:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.