Bug 1353321 - Selecting area to grab puts gnome-screenshot into a 100% CPU busy loop
Summary: Selecting area to grab puts gnome-screenshot into a 100% CPU busy loop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-screenshot
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1366035 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-06 18:52 UTC by Dimitris
Modified: 2016-08-27 10:29 UTC (History)
7 users (show)

Fixed In Version: gnome-screenshot-3.20.1-2.fc24 gnome-screenshot-3.20.1-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-18 03:50:33 UTC
Type: Bug


Attachments (Terms of Use)
pstack output (13.92 KB, text/plain)
2016-07-08 03:59 UTC, Dimitris
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 768087 None None None 2016-08-06 16:29:46 UTC

Description Dimitris 2016-07-06 18:52:12 UTC
Description of problem:

New after upgrading F23->F24:

Trying to grab a specific area of the screen puts g-s into a busy loop.  The copy/save dialog never appears.

Version-Release number of selected component (if applicable):

3.20.1-1.fc24

How reproducible:

Every time

Steps to Reproduce:
1. Windows/super key to overview mode, type "screenshot", select screenshot
2. Pick "Select area to grab"
3. Click on "Take Screenshot"
4. gnome-screenshot never responds, takes 100% of one core.

Actual results:

Spins the CPU

Expected results:

Should take a snapshot and present the save/copy to clipboard dialog.

Additional info:

Selecting "current window" responds with the next dialog after a short delay.
Selecting "whole screen" freezes the desktop for a while, but eventually responds with the dialog as well.

Comment 1 Rui Matos 2016-07-07 12:08:44 UTC
Unable to reproduce here. Can you install debuginfo packages for glib2, gtk3 and gnome-screenshot and then attach gdb to the process when it's burning CPU and get a few stack traces?

Comment 2 Dimitris 2016-07-08 01:38:00 UTC
Well, of course now I can't reproduce this.  I'll close and reopen if it happens again.

Comment 3 Dimitris 2016-07-08 03:59:31 UTC
Created attachment 1177518 [details]
pstack output

Happened again, attaching pstack output

Comment 4 Rui Matos 2016-07-11 12:34:08 UTC
Ok, reproduced, see https://bugzilla.gnome.org/show_bug.cgi?id=768087#c2 for a fix, I'll close this downstream bug.

Comment 5 Sascha Zantis 2016-08-03 18:11:34 UTC
Sorry if this comment reopens the bug, but I still see this issue. Will this be updated soon?

Comment 6 Dimitris 2016-08-06 16:29:46 UTC
Sorry about yet another me-too: This is pretty bad - it's even locked up the desktop to the point where I couldn't ctrl-alt-Fn to the console to kill the screenshot process or ctrl-shift-del (does that even work any more?) - had to hard reboot.  Any idea when a build with the fix (backported?) might be happening?

Comment 7 Fedora Update System 2016-08-16 09:48:04 UTC
gnome-screenshot-3.20.1-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-a75af83983

Comment 8 Fedora Update System 2016-08-16 09:49:39 UTC
gnome-screenshot-3.20.1-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-918b8a1023

Comment 9 Rui Matos 2016-08-16 11:58:35 UTC
*** Bug 1366035 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2016-08-16 16:25:46 UTC
gnome-screenshot-3.20.1-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-918b8a1023

Comment 11 Fedora Update System 2016-08-16 23:21:05 UTC
gnome-screenshot-3.20.1-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-a75af83983

Comment 12 Fedora Update System 2016-08-18 03:50:31 UTC
gnome-screenshot-3.20.1-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-08-27 10:29:54 UTC
gnome-screenshot-3.20.1-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.