Bug 1353357 - Enhancement: Add multipathd JSON API
Summary: Enhancement: Add multipathd JSON API
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath   
(Show other bugs)
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Zhang Yi
Steven J. Levine
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-06 22:18 UTC by Ben Marzinski
Modified: 2016-11-04 08:20 UTC (History)
9 users (show)

Fixed In Version: device-mapper-multipath-0.4.9-94.el7
Doc Type: Enhancement
Doc Text:
The "multipathd" command can now display the multipath data with JSON formatting With this release, multipathd now includes the "show maps json" command to display the multipath data with JSON formatting. This makes it easier for other programs to parse the "multipathd show maps" output.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 08:20:30 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2536 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2016-11-03 14:18:10 UTC

Description Ben Marzinski 2016-07-06 22:18:41 UTC
Upstream multipath-tools includes a "show maps json" command that allows it 
to return multipath map data in JSON format.  This makes it easier for applications to parse information from multipathd.

http://git.opensvc.com/gitweb.cgi?p=multipath-tools/.git;a=commit;h=8fb53a78f19069556edc5e1f1f30f9f58e4f43e8

This command should be backported to the RHEL-7.3 release.

Comment 4 Ben Marzinski 2016-07-15 23:24:50 UTC
Patches applied.

Comment 12 errata-xmlrpc 2016-11-04 08:20:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2536.html


Note You need to log in before you can comment on or make changes to this bug.