Bug 1353361 - install: cannot stat ?/usr/share/ipxe/undionly.kpxe?: No such file or directory
Summary: install: cannot stat ?/usr/share/ipxe/undionly.kpxe?: No such file or directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ipxe
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Jon Schlueter
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-06 22:54 UTC by Gonéri Le Bouder
Modified: 2016-08-16 04:08 UTC (History)
10 users (show)

Fixed In Version: ipxe-20160127-1.git6366fa7a.el7
Doc Type: Bug Fix
Doc Text:
The ipxe-bootimages RPM was not included in the repository for the director. This caused failure during director installation. This update adds the package to the director's repository. The RPM is now included as a part of the director's installation.
Clone Of:
Environment:
Last Closed: 2016-08-11 11:35:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC

Description Gonéri Le Bouder 2016-07-06 22:54:34 UTC
Description of problem:

A dependency on ipxe is missing, without ipxe-roms, undercloud creation fails with:

install: cannot stat ?/usr/share/ipxe/undionly.kpxe?: No such file or directory

Version-Release number of selected component (if applicable):
OSP9

OSP9.0: 016-07-04.2
OSP9.0-director: 2016-07-05.1

How reproducible:

install python-tripleoclient and deploy an undercloud. The installation will fail because of the error above.

If I try to install ipxe-bootimgs manually:
[stack@directorvm ~]$ sudo yum install ipxe-bootimgs
Loaded plugins: product-id, search-disabled-repos, subscription-manager
No package ipxe-bootimgs available.
Error: Nothing to do

The package is indeed missing unlike ipxe-roms.

Comment 2 Gonéri Le Bouder 2016-07-06 23:03:42 UTC
I realized rhel-7-server-optional-rpms was not enabled. I can now get ipxe-bootimgs installed BUT I only get the old version from RHEL7.2 ( 20130517-8.gitc4bce43.el7_2.1 ) without the --timeout support.

Comment 7 Gurenko Alex 2016-08-03 10:50:21 UTC
Deployed with CI release 9-latest successfully.

Comment 9 errata-xmlrpc 2016-08-11 11:35:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.