Bug 1353422 - alt+tab not being passed to RDP clients
Summary: alt+tab not being passed to RDP clients
Status: CLOSED DUPLICATE of bug 1285770
Alias: None
Product: Fedora
Classification: Fedora
Component: wayland
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Jon Disnard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: WaylandRelated
TreeView+ depends on / blocked
 
Reported: 2016-07-07 03:27 UTC by IanB
Modified: 2016-07-21 21:17 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-07-21 21:17:31 UTC


Attachments (Terms of Use)

Description IanB 2016-07-07 03:27:30 UTC
Description of problem:

Using Gnome shell with Wayland, and running rdesktop, the key combination alt+tab (used for switching windows) does not get passed to the remote desktop, instead causes local windows to switch. This only happens under Wayland. 

How reproducible: always


Steps to Reproduce:
1. Launch rdesktop session to remote host
2. open several windows on remote host
3. with mouse focus on rdesktop, press alt+tab to switch windows

Actual results:

windows on local Gnome session are switched


Expected results:

windows on remote host should be switched

Comment 1 IanB 2016-07-16 04:58:40 UTC
Initial testing was done with rdesktop, however I've discovered freerdp has the same issue.

Comment 2 Christian Stadelmann 2016-07-21 15:48:36 UTC
Duplicate of bug #1285770. Affects most or all remote desktop and virtual machine software.

Comment 3 IanB 2016-07-21 21:17:31 UTC

*** This bug has been marked as a duplicate of bug 1285770 ***


Note You need to log in before you can comment on or make changes to this bug.