Bug 1353452 - ipa-compat-manage command failed, exception: NotImplementedError: config.get_dn()
Summary: ipa-compat-manage command failed, exception: NotImplementedError: config.get_...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression, TestBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-07 06:49 UTC by Sudhir Menon
Modified: 2016-11-04 05:56 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:56:23 UTC


Attachments (Terms of Use)
Debug log (3.58 KB, text/plain)
2016-07-07 06:49 UTC, Sudhir Menon
no flags Details
compatmanage debug log (3.58 KB, text/plain)
2016-07-07 07:40 UTC, Sudhir Menon
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Sudhir Menon 2016-07-07 06:49:33 UTC
Created attachment 1177190 [details]
Debug log

Description of problem: when ipa-compat-manage enable command is run it gives message 'Directory Manager password: config.get_dn()' on the console.


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64

How reproducible: Always

Steps to Reproduce:
1. Install IPA server. 
2. now run the command echo Secret123|ipa-nis-manage enable
3. Check the result on the console

Actual results:
[root@server ~]# echo Secret123|ipa-nis-manage enable
Directory Manager password: 
config.get_dn()


Expected results:
It should display correct output.

Additional info: Attached debug log.

Comment 1 Sudhir Menon 2016-07-07 06:50:38 UTC
Same debug output is seen for enable/disable/status options.

Comment 4 Sudhir Menon 2016-07-07 07:40 UTC
Created attachment 1177207 [details]
compatmanage debug log

Comment 5 Sudhir Menon 2016-07-07 07:41:57 UTC
[root@server ~]# echo labs_pwd|ipa-compat-manage enable
Directory Manager password: 
config.get_dn()

[root@server ~]# echo labs_pwd|ipa-compat-manage disable
Directory Manager password: 
config.get_dn()

[root@server ~]# echo labs_pwd|ipa-compat-manage status
Directory Manager password: 
config.get_dn()

Comment 6 Petr Vobornik 2016-07-07 11:38:21 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6033

Comment 8 Petr Vobornik 2016-07-12 09:01:12 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/a5efeb449bba47dd430a7b8ffa594ace189252f4

Comment 10 Sudhir Menon 2016-07-15 13:00:22 UTC
Fix is seen. Verified using ipa-server-4.4.0-2.1.el7.x86_64

[root@server ~]# echo Secret123|ipa-compat-manage enable
Directory Manager password: 
Plugin already Enabled

[root@server ~]# ipa-compat-manage status
Directory Manager password: 
Plugin Enabled

Comment 12 errata-xmlrpc 2016-11-04 05:56:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.