Bug 135346 - tamil translation in application is not using UTF-8 encoding
Summary: tamil translation in application is not using UTF-8 encoding
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gail (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-12 03:41 UTC by Lawrence Lim
Modified: 2014-03-26 00:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 17:45:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Please find attached the latest copy of the po file. (9.30 KB, text/plain)
2004-10-12 04:07 UTC, Lawrence Lim
no flags Details

Description Lawrence Lim 2004-10-12 03:41:34 UTC
Description of problem:
Some of the tamil strings in ta.po is using the wrong encoding (TSCII
instead of UTF-8)

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. Run application in LANG=ta_IN.UTF-8
  
Actual results:
some strings are broken because of the encoding

Expected results:
should display all of the strings in UTF-8

Additional info:

Comment 1 Lawrence Lim 2004-10-12 04:07:18 UTC
Created attachment 105041 [details]
Please find attached the latest copy of the po file.

Comment 2 Leon Ho 2004-11-01 06:21:24 UTC
Just wanted to follow up if you have any timeframe on rebuilding the package for
RHEL4. It would be great to include the fixed tamil translation in because tamil
is one of our official supported languages. Thanks!

Comment 3 Matthias Clasen 2005-03-09 18:53:26 UTC
I have built gail-1.8.0-3.el4 in dist-4E-U2 now.

Comment 4 Lawrence Lim 2005-05-12 06:09:00 UTC
Confirmed fixed in EL4 with gail-1.8.0-3.el4. However, in FC4, gail-1.8.3-1, the
encoding is still broken.

Comment 5 Matthias Clasen 2005-05-18 18:20:54 UTC
I can't quite believe that, as the only difference between the .po
files is the creation date.

[mclasen@golem gail]$ diff -u devel/gail-1.8.3/po/ta.po RHEL-4/gail-1.8.0/po/ta.po
--- devel/gail-1.8.3/po/ta.po   2005-04-11 11:00:27.000000000 -0400
+++ RHEL-4/gail-1.8.0/po/ta.po  2004-09-13 03:31:53.000000000 -0400
@@ -7,7 +7,7 @@
 msgstr ""
 "Project-Id-Version: Tamil-Gail Gnome 2.6\n"
 "Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2005-04-11 16:00+0100\n"
+"POT-Creation-Date: 2004-03-15 10:59+0000\n"
 "PO-Revision-Date: 2004-02-23 17:25-0600\n"
 "Last-Translator: Dinesh Nadarajah <dinesh_list@sbcglobal.net>\n"
 "Language-Team: Tamil <tamillinux-user@lists.sourceforge.net>\n"


Comment 6 Matthias Clasen 2005-05-18 18:22:19 UTC
Ah, sorry. I spoke too soon. I did not update that RHEL4 directory in a loong
time...


Note You need to log in before you can comment on or make changes to this bug.