Bug 135347 - tamil translation in application is not using UTF-8 encoding
tamil translation in application is not using UTF-8 encoding
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: FC4Target 137149
  Show dependency treegraph
 
Reported: 2004-10-11 23:42 EDT by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 02:00:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Please find attached the latest copy of the po file. (32.93 KB, text/plain)
2004-10-12 00:07 EDT, Lawrence Lim
no flags Details
based on dave's test case 1 (161.77 KB, image/png)
2004-12-06 01:16 EST, Lawrence Lim
no flags Details
based on dave's test case 2 (131.01 KB, image/png)
2004-12-06 01:16 EST, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2004-10-11 23:42:08 EDT
Description of problem:
Some of the tamil strings in ta.po is using the wrong encoding (TSCII
instead of UTF-8)

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. Run application in LANG=ta_IN.UTF-8
  
Actual results:
some strings are broken because of the encoding

Expected results:
should display all of the strings in UTF-8

Additional info:
Comment 1 Lawrence Lim 2004-10-12 00:07:52 EDT
Created attachment 105042 [details]
Please find attached the latest copy of the po file.
Comment 2 Leon Ho 2004-11-01 01:20:34 EST
Just wanted to follow up if you have any timeframe on rebuilding the package for
RHEL4. It would be great to include the fixed tamil translation in because tamil
is one of our official supported languages. Thanks!
Comment 3 Dave Malcolm 2004-11-18 17:14:12 EST
This bug has been assigned to component "gal".  Is this file for the
"gal" package, or for "libgal2"?  Evolution uses libgal2.
Comment 4 Dave Malcolm 2004-11-18 17:16:20 EST
Removing from FC3Target tracker (bug #123268); adding to RHEL4 i18n
tracker (bug #137149).
Comment 5 Lawrence Lim 2004-11-18 23:52:15 EST
I think it is for gal package.

[snip]
# translation of ta.po to Tamil
# Tamil Translation of gal.pot
# Copyright (C) 2001, 2004 Free Software Foundation, Inc.
# Dinesh Nadarajah <n_dinesh@yahoo.com>, 2001.
# Jayaradha N <jaya@pune.redhat.com>, 2004.
#
Comment 6 Dave Malcolm 2004-12-02 17:16:33 EST
I can't find anything that actually uses the "gal" package.

I've built a new version of the libgal2 package for RHEL 4
(libgal2-2:2.2.3-4) which contains the new ta.po file from the
attachment in comment #1.  

I checked upstream (GNOME) CVS and the same file has already been
committed there (in the "gnome-2-8" branch of the "gal" module).

The new package is in dist-4E-HEAD, so it will need moving.
Comment 7 Dave Malcolm 2004-12-02 17:24:29 EST
To test the libgal2 package, try running Evolution e.g.:
LANG=ta_IN.UTF-8 evolution

Strings from libgal2 package are used in the following places:
(i) in the Mail component, try right-clicking on the message list
header; the popup menu has various options for adding/removing
columns; the dialogs presented here (and hence the strings) are from
libgal2
(although the column headings themselves are from Evolution)
(ii) in the Contacts component, try opening a contact, and clicking on
the Categories button; in the next dialog try clicking on the Edit
Master Category List button; I believe that all the strings you'll see
here are from libgal2
Comment 8 Dave Malcolm 2004-12-02 17:34:44 EST
I've filed this Late Revision Process bug to cover this:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=141686
Comment 9 Lawrence Lim 2004-12-06 01:15:38 EST
Thanks for the Test Case, Dave. :) 
 
Unfortunately, I dont understand tamil as well, so I'm cc'ing sarah, 
hopefully she will give me a hand on this. 
 
Sarah, 
Based on Dave's Test Case, I have attached 2 screenshots in this bug. 
Could you please ask the translator to verify if the translation is 
correct? 
 
 
Thanks. 
Comment 10 Lawrence Lim 2004-12-06 01:16:20 EST
Created attachment 107926 [details]
based on dave's test case 1
Comment 11 Lawrence Lim 2004-12-06 01:16:52 EST
Created attachment 107927 [details]
based on dave's test case 2
Comment 12 Sarah Wang 2004-12-06 17:50:54 EST
Tamil translator is on leave. I'm unable to verify it at this stage.

Sarah
Comment 13 Lawrence Lim 2005-05-12 02:00:55 EDT
Verified with both FC4 and EL4, the encoding looks good.

Note You need to log in before you can comment on or make changes to this bug.