Bug 1353479 - [Gdeploy+nfs-ganesha]: nfs-ganesha and related packages couldn't be validated by gdeploy.
Summary: [Gdeploy+nfs-ganesha]: nfs-ganesha and related packages couldn't be validated...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.2.0
Assignee: Sachidananda Urs
QA Contact: Manisha Saini
URL:
Whiteboard:
Depends On:
Blocks: 1351522
TreeView+ depends on / blocked
 
Reported: 2016-07-07 09:00 UTC by Shashank Raj
Modified: 2017-03-23 04:57 UTC (History)
9 users (show)

Fixed In Version: gdeploy-2.0.1-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 04:57:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0483 0 normal SHIPPED_LIVE gdeploy bug fix and enhancement update 2017-03-23 08:56:29 UTC

Description Shashank Raj 2016-07-07 09:00:24 UTC
Description of problem:

nfs-ganesha and related packages couldn't be validated by gdeploy.

Even though the packages (nfs-ganesha, pacemaker and corosync) are present and installed on the systems, gedploy gives a fail message saying "package XXXX is not installed"

>>>> Snippet from gdeploy logs:

PLAY [cluster_nodes] ********************************************************** 

TASK: [Check if nfs-ganesha is installed] ************************************* 
changed: [10.70.42.107]
changed: [10.70.42.81]
changed: [10.70.42.112]
changed: [10.70.42.80]

TASK: [fail msg="Package nfs-ganesha is not installed"] *********************** 
skipping: [10.70.42.107]
skipping: [10.70.42.112]
skipping: [10.70.42.80]
skipping: [10.70.42.81]

TASK: [Check if corosync is installed] **************************************** 
changed: [10.70.42.107]
changed: [10.70.42.112]
changed: [10.70.42.80]
changed: [10.70.42.81]

TASK: [fail msg="Package corosync is not installed"] ************************** 
skipping: [10.70.42.107]
skipping: [10.70.42.80]
skipping: [10.70.42.112]
skipping: [10.70.42.81]

TASK: [Check if pacemaker is installed] *************************************** 
changed: [10.70.42.107]
changed: [10.70.42.81]
changed: [10.70.42.80]
changed: [10.70.42.112]

TASK: [fail msg="Package pacemaker is not installed"] ************************* 
skipping: [10.70.42.107]
skipping: [10.70.42.80]
skipping: [10.70.42.81]
skipping: [10.70.42.112]

PLAY [cluster_nodes] ********************************************************** 

>>>> packages installed on the systems:

[root@dhcp42-107 ~]# rpm -qa|grep ganesha
nfs-ganesha-2.3.1-8.el7rhgs.x86_64
nfs-ganesha-gluster-2.3.1-8.el7rhgs.x86_64
glusterfs-ganesha-3.7.9-10.el7rhgs.x86_64

[root@dhcp42-107 ~]# rpm -qa|grep pcs
pcs-0.9.143-15.el7.x86_64

[root@dhcp42-107 ~]# rpm -qa|grep pacemaker
pacemaker-1.1.13-10.el7_2.2.x86_64
pacemaker-cli-1.1.13-10.el7_2.2.x86_64
pacemaker-cluster-libs-1.1.13-10.el7_2.2.x86_64
pacemaker-libs-1.1.13-10.el7_2.2.x86_64

[root@dhcp42-107 ~]# rpm -qa|grep corosync
corosynclib-2.3.4-7.el7_2.3.x86_64
corosync-2.3.4-7.el7_2.3.x86_64

Version-Release number of selected component (if applicable):

gdeploy-2.0-16.noarch

How reproducible:

Always

Steps to Reproduce:

1. Install relevant 3.1.3 RHGS and nfs-ganesha packages.
2. Start the nfs-ganesha setup using gdeploy.
3. Observe that during package verification, gdeploy gives failed message saying "package xxxxx is not installed"

TASK: [Check if nfs-ganesha is installed] ************************************* 
changed: [10.70.42.107]
changed: [10.70.42.81]
changed: [10.70.42.112]
changed: [10.70.42.80]

TASK: [fail msg="Package nfs-ganesha is not installed"] *********************** 
skipping: [10.70.42.107]
skipping: [10.70.42.112]
skipping: [10.70.42.80]
skipping: [10.70.42.81]

TASK: [Check if corosync is installed] **************************************** 
changed: [10.70.42.107]
changed: [10.70.42.112]
changed: [10.70.42.80]
changed: [10.70.42.81]

TASK: [fail msg="Package corosync is not installed"] ************************** 
skipping: [10.70.42.107]
skipping: [10.70.42.80]
skipping: [10.70.42.112]
skipping: [10.70.42.81]

TASK: [Check if pacemaker is installed] *************************************** 
changed: [10.70.42.107]
changed: [10.70.42.81]
changed: [10.70.42.80]
changed: [10.70.42.112]

TASK: [fail msg="Package pacemaker is not installed"] ************************* 
skipping: [10.70.42.107]
skipping: [10.70.42.80]
skipping: [10.70.42.81]
skipping: [10.70.42.112]

Even though the relevant packages are present on the systems:

[root@dhcp42-107 ~]# rpm -qa|grep ganesha
nfs-ganesha-2.3.1-8.el7rhgs.x86_64
nfs-ganesha-gluster-2.3.1-8.el7rhgs.x86_64
glusterfs-ganesha-3.7.9-10.el7rhgs.x86_64

[root@dhcp42-107 ~]# rpm -qa|grep pcs
pcs-0.9.143-15.el7.x86_64

[root@dhcp42-107 ~]# rpm -qa|grep pacemaker
pacemaker-1.1.13-10.el7_2.2.x86_64
pacemaker-cli-1.1.13-10.el7_2.2.x86_64
pacemaker-cluster-libs-1.1.13-10.el7_2.2.x86_64
pacemaker-libs-1.1.13-10.el7_2.2.x86_64

[root@dhcp42-107 ~]# rpm -qa|grep corosync
corosynclib-2.3.4-7.el7_2.3.x86_64
corosync-2.3.4-7.el7_2.3.x86_64

Actual results:

nfs-ganesha and related packages couldn't be validated by gdeploy.

Expected results:

When the relevant packages are installed, gdeploy shouldn't give error saying "package is not installed"

Additional info:

Comment 2 Sachidananda Urs 2016-07-08 09:36:28 UTC
The following packages have to be checked for NFS Ganesha:

[root@dhcp42-107 ~]# rpm -qa|grep ganesha
nfs-ganesha-2.3.1-8.el7rhgs.x86_64
nfs-ganesha-gluster-2.3.1-8.el7rhgs.x86_64
glusterfs-ganesha-3.7.9-10.el7rhgs.x86_64

[root@dhcp42-107 ~]# rpm -qa|grep pcs
pcs-0.9.143-15.el7.x86_64

[root@dhcp42-107 ~]# rpm -qa|grep pacemaker
pacemaker-1.1.13-10.el7_2.2.x86_64
pacemaker-cli-1.1.13-10.el7_2.2.x86_64
pacemaker-cluster-libs-1.1.13-10.el7_2.2.x86_64
pacemaker-libs-1.1.13-10.el7_2.2.x86_64

[root@dhcp42-107 ~]# rpm -qa|grep corosync
corosynclib-2.3.4-7.el7_2.3.x86_64
corosync-2.3.4-7.el7_2.3.x86_64

And

libntirpc-1.3

Comment 3 Sachidananda Urs 2016-07-12 13:54:40 UTC
Shashank,


(In reply to Shashank Raj from comment #0)
> Description of problem:
> 
> nfs-ganesha and related packages couldn't be validated by gdeploy.
> 
> Even though the packages (nfs-ganesha, pacemaker and corosync) are present
> and installed on the systems, gedploy gives a fail message saying "package
> XXXX is not installed"
> 
> >>>> Snippet from gdeploy logs:
> 
> PLAY [cluster_nodes]
> ********************************************************** 
> 
> TASK: [Check if nfs-ganesha is installed]
> ************************************* 
> changed: [10.70.42.107]
> changed: [10.70.42.81]
> changed: [10.70.42.112]
> changed: [10.70.42.80]
> 
> TASK: [fail msg="Package nfs-ganesha is not installed"]
> *********************** 
> skipping: [10.70.42.107]
> skipping: [10.70.42.112]
> skipping: [10.70.42.80]
> skipping: [10.70.42.81]

This is wrong message wording. Actually it has not failed, you can see:

skipping: [10.70.42.107] ...

I will change the messaging.

Comment 7 Manisha Saini 2016-11-15 05:28:22 UTC
Verified this bug on

[root@dhcp37-126 yum.repos.d]# rpm -qa | grep gdeploy
gdeploy-2.0.1-3.el7rhgs.noarch

glusterfs-3.8.4-5.el7rhgs.x86_64

No more failed package messages are observed.


PLAY [cluster_nodes] ***********************************************************

TASK [Check if nfs-ganesha is installed] ***************************************
changed: [dhcp37-126.lab.eng.blr.redhat.com]
 [WARNING]: Consider using yum, dnf or zypper module rather than running rpm

changed: [dhcp37-198.lab.eng.blr.redhat.com]
changed: [dhcp37-141.lab.eng.blr.redhat.com]
changed: [dhcp37-201.lab.eng.blr.redhat.com]

TASK [fail] ********************************************************************
skipping: [dhcp37-201.lab.eng.blr.redhat.com]
skipping: [dhcp37-141.lab.eng.blr.redhat.com]
skipping: [dhcp37-198.lab.eng.blr.redhat.com]
skipping: [dhcp37-126.lab.eng.blr.redhat.com]

TASK [Check if corosync is installed] ******************************************
changed: [dhcp37-198.lab.eng.blr.redhat.com]
changed: [dhcp37-201.lab.eng.blr.redhat.com]
changed: [dhcp37-126.lab.eng.blr.redhat.com]
changed: [dhcp37-141.lab.eng.blr.redhat.com]

TASK [fail] ********************************************************************
skipping: [dhcp37-141.lab.eng.blr.redhat.com]
skipping: [dhcp37-198.lab.eng.blr.redhat.com]
skipping: [dhcp37-201.lab.eng.blr.redhat.com]
skipping: [dhcp37-126.lab.eng.blr.redhat.com]

TASK [Check if pacemaker is installed] *****************************************
changed: [dhcp37-198.lab.eng.blr.redhat.com]
changed: [dhcp37-126.lab.eng.blr.redhat.com]
changed: [dhcp37-201.lab.eng.blr.redhat.com]
changed: [dhcp37-141.lab.eng.blr.redhat.com]

TASK [fail] ********************************************************************
skipping: [dhcp37-201.lab.eng.blr.redhat.com]
skipping: [dhcp37-141.lab.eng.blr.redhat.com]
skipping: [dhcp37-198.lab.eng.blr.redhat.com]
skipping: [dhcp37-126.lab.eng.blr.redhat.com]

TASK [Check if libntirpc is installed] *****************************************
changed: [dhcp37-198.lab.eng.blr.redhat.com]
changed: [dhcp37-126.lab.eng.blr.redhat.com]
changed: [dhcp37-201.lab.eng.blr.redhat.com]
changed: [dhcp37-141.lab.eng.blr.redhat.com]

TASK [fail] ********************************************************************
skipping: [dhcp37-198.lab.eng.blr.redhat.com]
skipping: [dhcp37-141.lab.eng.blr.redhat.com]
skipping: [dhcp37-126.lab.eng.blr.redhat.com]
skipping: [dhcp37-201.lab.eng.blr.redhat.com]

TASK [Check if pcs is installed] ***********************************************
changed: [dhcp37-198.lab.eng.blr.redhat.com]
changed: [dhcp37-126.lab.eng.blr.redhat.com]
changed: [dhcp37-201.lab.eng.blr.redhat.com]
changed: [dhcp37-141.lab.eng.blr.redhat.com]

TASK [fail] ********************************************************************
skipping: [dhcp37-201.lab.eng.blr.redhat.com]
skipping: [dhcp37-126.lab.eng.blr.redhat.com]
skipping: [dhcp37-198.lab.eng.blr.redhat.com]
skipping: [dhcp37-141.lab.eng.blr.redhat.com]

Comment 9 errata-xmlrpc 2017-03-23 04:57:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2017-0483.html


Note You need to log in before you can comment on or make changes to this bug.