Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
DescriptionNikhil Dehadrai
2016-07-07 10:47:56 UTC
Created attachment 1177248[details]
Console Output log for migrate ds command
Description of problem:
ipa migrate-ds command fails for IPA in RHEL 7.3 as a result migration of users fails.
Version-Release number of selected component (if applicable):
ipa server version: ipa-server-4.4.0-1.el7.x86_64
How reproducible:
Always
Steps to Reproduce:
1. Setup DS server.
2. Setup IPA server on RHEL 7.3
3. Run following command
"ipa migrate-ds --user-container="ou=People" --group-container="ou=groups" --with-compat ldap://ldap_server.example.com:389"
Actual results:
After step3, following error message is received:
ipa: ERROR: TypeError: output_for_cli() takes exactly 5 arguments (4 given)
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1350, in run
sys.exit(api.Backend.cli.run(argv))
File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1115, in run
rv = cmd.output_for_cli(self.api.Backend.textui, result, *args, **options)
TypeError: output_for_cli() takes exactly 5 arguments (4 given)
ipa: ERROR: an internal error has occurred
Expected results:
No error messages should be observed and the command should execute correctly.
Additional info:
The same command when run on RHEL 7.2z, runs correctly.
Refer attachment.
server version: ipa-server-4.4.0-2.1.el7.x86_64
Verified the bug on the basis of following observations:
1. Verified that on running the following command on IPA server does not return any error message as mentioned inside the bug.
"ipa migrate-ds --user-container="ou=People" --group-container="ou=groups" --with-compat ldap://ldap_server.example.com:389"
2. Refer attachment for the verification steps.
Thus, marking the status of bug to "VERIFIED".
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://rhn.redhat.com/errata/RHBA-2016-2404.html
Created attachment 1177248 [details] Console Output log for migrate ds command Description of problem: ipa migrate-ds command fails for IPA in RHEL 7.3 as a result migration of users fails. Version-Release number of selected component (if applicable): ipa server version: ipa-server-4.4.0-1.el7.x86_64 How reproducible: Always Steps to Reproduce: 1. Setup DS server. 2. Setup IPA server on RHEL 7.3 3. Run following command "ipa migrate-ds --user-container="ou=People" --group-container="ou=groups" --with-compat ldap://ldap_server.example.com:389" Actual results: After step3, following error message is received: ipa: ERROR: TypeError: output_for_cli() takes exactly 5 arguments (4 given) Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1350, in run sys.exit(api.Backend.cli.run(argv)) File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1115, in run rv = cmd.output_for_cli(self.api.Backend.textui, result, *args, **options) TypeError: output_for_cli() takes exactly 5 arguments (4 given) ipa: ERROR: an internal error has occurred Expected results: No error messages should be observed and the command should execute correctly. Additional info: The same command when run on RHEL 7.2z, runs correctly. Refer attachment.