Bug 1353506 - ipa migrate-ds command fails for IPA in RHEL 7.3
Summary: ipa migrate-ds command fails for IPA in RHEL 7.3
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-07 10:47 UTC by Nikhil Dehadrai
Modified: 2016-11-04 05:56 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:56:27 UTC


Attachments (Terms of Use)
Console Output log for migrate ds command (2.41 KB, text/plain)
2016-07-07 10:47 UTC, Nikhil Dehadrai
no flags Details
Verification Steps-Console output log (427 bytes, text/plain)
2016-07-19 03:24 UTC, Nikhil Dehadrai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Nikhil Dehadrai 2016-07-07 10:47:56 UTC
Created attachment 1177248 [details]
Console Output log for migrate ds command

Description of problem:
ipa migrate-ds command fails for IPA in RHEL 7.3 as a result migration of users fails.

Version-Release number of selected component (if applicable):
ipa server version: ipa-server-4.4.0-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Setup DS server.
2. Setup IPA server on RHEL 7.3
3. Run following command
"ipa migrate-ds --user-container="ou=People" --group-container="ou=groups" --with-compat ldap://ldap_server.example.com:389"

Actual results:
After step3, following error message is received:
ipa: ERROR: TypeError: output_for_cli() takes exactly 5 arguments (4 given)
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1350, in run
    sys.exit(api.Backend.cli.run(argv))
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1115, in run
    rv = cmd.output_for_cli(self.api.Backend.textui, result, *args, **options)
TypeError: output_for_cli() takes exactly 5 arguments (4 given)
ipa: ERROR: an internal error has occurred

Expected results:
No error messages should be observed and the command should execute correctly.

Additional info:
The same command when run on RHEL 7.2z, runs correctly.
Refer attachment.

Comment 3 Petr Vobornik 2016-07-07 11:40:13 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6034

Comment 4 Petr Vobornik 2016-07-13 16:42:40 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/6c74bd2bcca46b586b07c3acd9670dae6e1f07b9

Comment 6 Nikhil Dehadrai 2016-07-19 03:22:39 UTC
server version: ipa-server-4.4.0-2.1.el7.x86_64

Verified the bug on the basis of following observations:
1. Verified that on running the following command on IPA server does not return any error message as mentioned inside the bug.

"ipa migrate-ds --user-container="ou=People" --group-container="ou=groups" --with-compat ldap://ldap_server.example.com:389"

2. Refer attachment for the verification steps.

Thus, marking the status of bug to "VERIFIED".

Comment 7 Nikhil Dehadrai 2016-07-19 03:24 UTC
Created attachment 1181405 [details]
Verification Steps-Console output log

Verification Steps-Console output log

Comment 9 errata-xmlrpc 2016-11-04 05:56:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.