Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1353506

Summary: ipa migrate-ds command fails for IPA in RHEL 7.3
Product: Red Hat Enterprise Linux 7 Reporter: Nikhil Dehadrai <ndehadra>
Component: ipaAssignee: IPA Maintainers <ipa-maint>
Status: CLOSED ERRATA QA Contact: Kaleem <ksiddiqu>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.3CC: pvoborni, rcritten
Target Milestone: rcKeywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ipa-4.4.0-2.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2016-11-04 05:56:27 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
Console Output log for migrate ds command
none
Verification Steps-Console output log none

Description Nikhil Dehadrai 2016-07-07 10:47:56 UTC
Created attachment 1177248 [details]
Console Output log for migrate ds command

Description of problem:
ipa migrate-ds command fails for IPA in RHEL 7.3 as a result migration of users fails.

Version-Release number of selected component (if applicable):
ipa server version: ipa-server-4.4.0-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Setup DS server.
2. Setup IPA server on RHEL 7.3
3. Run following command
"ipa migrate-ds --user-container="ou=People" --group-container="ou=groups" --with-compat ldap://ldap_server.example.com:389"

Actual results:
After step3, following error message is received:
ipa: ERROR: TypeError: output_for_cli() takes exactly 5 arguments (4 given)
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1350, in run
    sys.exit(api.Backend.cli.run(argv))
  File "/usr/lib/python2.7/site-packages/ipalib/cli.py", line 1115, in run
    rv = cmd.output_for_cli(self.api.Backend.textui, result, *args, **options)
TypeError: output_for_cli() takes exactly 5 arguments (4 given)
ipa: ERROR: an internal error has occurred

Expected results:
No error messages should be observed and the command should execute correctly.

Additional info:
The same command when run on RHEL 7.2z, runs correctly.
Refer attachment.

Comment 3 Petr Vobornik 2016-07-07 11:40:13 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6034

Comment 4 Petr Vobornik 2016-07-13 16:42:40 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/6c74bd2bcca46b586b07c3acd9670dae6e1f07b9

Comment 6 Nikhil Dehadrai 2016-07-19 03:22:39 UTC
server version: ipa-server-4.4.0-2.1.el7.x86_64

Verified the bug on the basis of following observations:
1. Verified that on running the following command on IPA server does not return any error message as mentioned inside the bug.

"ipa migrate-ds --user-container="ou=People" --group-container="ou=groups" --with-compat ldap://ldap_server.example.com:389"

2. Refer attachment for the verification steps.

Thus, marking the status of bug to "VERIFIED".

Comment 7 Nikhil Dehadrai 2016-07-19 03:24:09 UTC
Created attachment 1181405 [details]
Verification Steps-Console output log

Verification Steps-Console output log

Comment 9 errata-xmlrpc 2016-11-04 05:56:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html