Bug 1353511 - Renaming a snapshot on Master Node is not getting reflected at Slave Node
Summary: Renaming a snapshot on Master Node is not getting reflected at Slave Node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 2.0
Assignee: Jason Dillaman
QA Contact: Tanay Ganguly
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-07 11:01 UTC by Tanay Ganguly
Modified: 2017-07-30 15:33 UTC (History)
5 users (show)

Fixed In Version: RHEL: ceph-10.2.2-22.el7cp Ubuntu: ceph_10.2.2-17redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:43:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 16622 None None None 2016-07-07 22:26:41 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Tanay Ganguly 2016-07-07 11:01:24 UTC
Description of problem:
Rename the snapshot on Master Node, the renamed snapshot doesn't get reflected on Slave Node.

Version-Release number of selected component (if applicable):
ceph version 10.2.2-15.el7cp

How reproducible:
Always

Steps to Reproduce:
1. Create an Image.
rbd create new/renameq --size 9999 --image-format 2 --image-feature layering,exclusive-lock,object-map,journaling --cluster master

2. Take a snapshot.
rbd snap create new/renameq@latest --cluster master

3. Rename Snapshot
rbd snap rename new/renameq@latest new/renameq@latest-renamed --cluster master
 

Actual results:
New Snapshot name gets reflected in Master Node. But the same is not getting reflected on Slave Node.

Expected results:
On Slave Node also the renamed snapshot should show up.

Additional info:

Comment 4 Jason Dillaman 2016-07-11 22:00:53 UTC
Upstream master branch PR: https://github.com/ceph/ceph/pull/10249

Comment 8 Tanay Ganguly 2016-07-25 09:13:23 UTC
Working Fine, Marking it as Verified.

Comment 10 errata-xmlrpc 2016-08-23 19:43:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.