Bug 135356 - disable backspace_deletes_character for hangul and hiragana
disable backspace_deletes_character for hangul and hiragana
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 00:21 EDT by Leon Ho
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 22:38:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing both GTK+ bugs (5.75 KB, text/plain)
2004-10-20 02:18 EDT, Owen Taylor
no flags Details
Smaller GTK+ fix (1.74 KB, patch)
2004-10-20 11:15 EDT, Owen Taylor
no flags Details | Diff

  None (edit)
Description Leon Ho 2004-10-12 00:21:34 EDT
Description of problem:
Currently because of the backport of this feature, korean and japanese
users may not be so familiar with current behavior with current input.

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. wget
http://www.openi18n.org/subgroups/testsuites/1.3/interactive/text-editor-tests/UTF-8.txt
2. gedit UTF-8.txt
3. go to hangul or hiragana end char and press backspace
  
Actual results:
delete syllable

Expected results:
delete the whole character

Additional info:
Please see bug 132189
Comment 1 Owen Taylor 2004-10-19 20:26:07 EDT
Upstreamed as http://bugzilla.gnome.org/show_bug.cgi?id=155897.

pango-1.6.0-6 (now building) should fix. Testing appreciated.
Comment 2 Leon Ho 2004-10-19 23:35:05 EDT
I have upgraded pango, re-run application and used the steps again and
I still able to delete indivi. Jamo on Hangul and delete the syllable
in hiragana. any ideas?
Comment 3 Owen Taylor 2004-10-20 00:42:39 EDT
Blech! Turns out that the GTK+ patches are flawed. 
 
 - GtkTextView doesn't check the backspace_deletes_charactre 
   flag at all

 - GtkEntry checks the flag on the wrong character
Comment 4 Owen Taylor 2004-10-20 02:18:56 EDT
Created attachment 105494 [details]
Patch fixing both GTK+ bugs

I'm attaching a patch against GTK+ HEAD that fixes both problems.
I had to move the backspace logic into gtktextbuffer.c since it
needed API that GtkTextView isn't supposed to use. (GtkTextView
is supposed to work from only GtkTextBuffer public API)

If lucky it should probably apply against the GTK+-2.4 backports
as well, though it would be nice to regendiff to get a merge,
and probably also good to rename gtk_text_buffer_backspace()
to _gtk_text_buffer_backspace() for the backport. (Hmm, I think
I forgot to makes a header file addition for the new function
in this patch)

To get things working fully also requires the Pango patch in
http://bugzilla.gnome.org/show_bug.cgi?id=155912

I can't get my VPN working now, so I'll look at building fixed
packages in the morning.
Comment 5 Owen Taylor 2004-10-20 11:15:46 EDT
Created attachment 105514 [details]
Smaller GTK+ fix

Here's a smaller patch to the same effect as the above. It's not kosher
for upstream because of the use of GtkTextBuffer private functions in
gtktextview but should be fine for the backport.
Comment 6 Owen Taylor 2004-10-20 13:26:45 EDT
pango-1.6.0-7 has the Pango patch
gtk+-2.4.13-2 has the GTK+ patch

I've tested bits of this locally pretty thoroughly and everything
seems to work well. But additional testing still appreciated.
Comment 7 Lawrence Lim 2004-10-20 22:38:42 EDT
Confirmed fixed. Tested with pango-1.6.0-7 and gtk2-2.4.13-2.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.