Bug 1353672 - Hindi-IN Hunspell method misprints character.
Summary: Hindi-IN Hunspell method misprints character.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mike FABIAN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-07 16:40 UTC by Nirmal Pathak
Modified: 2016-08-23 15:22 UTC (History)
5 users (show)

Fixed In Version: ibus-typing-booster-1.4.7-1.fc24 ibus-typing-booster-1.5.0-1.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 15:22:19 UTC
Type: Bug


Attachments (Terms of Use)
hi-in-typing-booster-preferences.png (13.34 KB, image/png)
2016-07-08 11:32 UTC, Mike FABIAN
no flags Details
F24 Screenshot with ibus-typing-booster test package. (527.94 KB, image/png)
2016-07-14 17:27 UTC, Nirmal Pathak
no flags Details

Description Nirmal Pathak 2016-07-07 16:40:08 UTC
Description of problem:
The Hindi-IN Hunspell method misprints character when "." is typed.

Version-Release number of selected component (if applicable): ibus-typing-booster-1.4.5-1.fc24


How reproducible:
Select Hindi-IN Hunspell method as input source & type "."

Steps to Reproduce:
1. Select Hindi-IN (Hunspell) method as input source.
2. Open gedit & type "."


Actual results:
.

Expected results:
। 

Additional info:

Comment 1 Mike FABIAN 2016-07-08 11:32:50 UTC
Created attachment 1177619 [details]
hi-in-typing-booster-preferences.png

I have problems reproducing this.
You are using the  "Phonetic" input method as shown in the screen shot
of the setup tool of the "hi-IN" ibus-typing-booster?

The "phonetic" input method seems to be the only one which transliterates
"." to । U+0964 DEVANAGARI DANDA.

And this seems to work for me, when  I type ".", I do get "।".

So I wonder how to reproduce the problem ...

Comment 2 Nirmal Pathak 2016-07-08 14:39:19 UTC
I am using "Itrans" input method.

Can you try using "Itrans"?

Comment 3 Mike FABIAN 2016-07-09 05:49:36 UTC
Even with Itrans, I cannot reproduce it.

/usr/share/m17n/hi-itrans.mim contains:

 (danda
  (".." "।")			      ; not in ITRANS Devanagari table
  (".," "॥")			      ; not in ITRANS Devanagari table
  (". " "।" (pushback 1))
  ((?. Return) "।" (pushback 1))
  ((?. Tab) "।" (pushback 1))
  (".(" "।" (pushback 1))
  (".)" "।" (pushback 1))
  (".[" "।" (pushback 1))
  (".]" "।" (pushback 1))
  (".{" "।" (pushback 1))
  (".}" "।" (pushback 1))
  (".'" "।" (pushback 1))
  (".\"" "।" (pushback 1)))

These all seem to work fine for me, both in the hi-IN ibus-typing-booster
using itrans, and in ibus-m17n using hi-itrans.

When using ibus-typing-booster, typing a . shows an underlined . (that shows that the . is still in preëdit) because it is waiting for another character.

Typing ".a" gives ऽ, both in ibus-typing-booster and in ibus-m17n.

Comment 4 Mike FABIAN 2016-07-09 07:01:08 UTC
A chat with Nirmal clarified that ". ", "." followed by Tab and  "." followed by Return don’t work. Thinking  how to fix that ...

Comment 5 Fedora Update System 2016-07-11 14:56:17 UTC
ibus-typing-booster-1.4.7-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4dff7802ff

Comment 6 Fedora Update System 2016-07-11 14:57:15 UTC
ibus-typing-booster-1.4.7-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-64cb2a9190

Comment 7 Fedora Update System 2016-07-11 14:57:57 UTC
ibus-typing-booster-1.4.7-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b20943166b

Comment 8 Fedora Update System 2016-07-12 03:26:48 UTC
ibus-typing-booster-1.4.7-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4dff7802ff

Comment 9 Fedora Update System 2016-07-12 03:54:25 UTC
ibus-typing-booster-1.4.7-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-64cb2a9190

Comment 10 Fedora Update System 2016-07-12 03:58:09 UTC
ibus-typing-booster-1.4.7-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b20943166b

Comment 11 Nirmal Pathak 2016-07-14 17:27:32 UTC
Created attachment 1179915 [details]
F24 Screenshot with ibus-typing-booster test package.

Seems like the issue is still not fixed. Check the attached screenshot.

I have installed ibus-typing-booster-1.4.7-1.fc24 package from test repository.

Am I missing something?

Comment 12 Mike FABIAN 2016-07-15 07:35:03 UTC
Did you restart ibus "ibus restart" after installing the package?
The underlined . you see in the screenshot might be OK, it is still waiting
for further input. After typing a space or RETURN it should turn into a "।".

But the "C-c" at the beginning of the line looks strange, this looks as if you
are still using the old version.

Comment 13 Mike FABIAN 2016-07-16 04:08:08 UTC
Nirmal  reports in chat that the changes are working fine for "।" after "ibus restart".

Comment 14 Fedora Update System 2016-07-18 04:20:04 UTC
ibus-typing-booster-1.4.8-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-52131892ac

Comment 15 Fedora Update System 2016-07-18 04:20:51 UTC
ibus-typing-booster-1.4.8-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-dfa7430438

Comment 16 Fedora Update System 2016-07-18 18:23:13 UTC
ibus-typing-booster-1.4.7-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2016-07-18 21:52:40 UTC
ibus-typing-booster-1.4.8-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-52131892ac

Comment 18 Fedora Update System 2016-07-18 22:24:17 UTC
ibus-typing-booster-1.4.8-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-dfa7430438

Comment 19 Fedora Update System 2016-08-12 12:56:51 UTC
ibus-typing-booster-1.5.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b5d93a9b45

Comment 20 Fedora Update System 2016-08-12 20:51:51 UTC
ibus-typing-booster-1.5.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b5d93a9b45

Comment 21 Fedora Update System 2016-08-23 15:22:09 UTC
ibus-typing-booster-1.5.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.