Bug 1353804 - The docker-registry and router deploy failed for 3.3
Summary: The docker-registry and router deploy failed for 3.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Troy Dawson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 03:43 UTC by zhou ying
Modified: 2016-09-27 09:39 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1353830 (view as bug list)
Environment:
Last Closed: 2016-09-27 09:39:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description zhou ying 2016-07-08 03:43:24 UTC
Description of problem:
After install the ose3.3 env, the docker-registry and router deploy failed

Version-Release number of selected component (if applicable):
openshift v3.3.0.2
kubernetes v1.3.0-alpha.3-599-g2746284
etcd 2.3.0+git
brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/ose-docker-registry:v3.3.0.2
brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/ose-haproxy-router:v3.3.0.2



How reproducible:
Always

Steps to Reproduce:
1. Install ose3.3 env;
2. Check the docker-registry and router pod;


Actual results:
2. The docker-registry and router deploy failed , with logs:


    [root@openshift-148 ~]# oc logs docker-registry-3-zxenp
    time="2016-07-07T22:18:32.031258874-04:00" level=info msg="version=v2.1.0+unknown"
    panic: unable to configure storage middleware (openshift): no storage middleware registered with name: openshift
     
    goroutine 1 [running]:
    github.com/docker/distribution/registry/handlers.NewApp(0x7f1f2f573c40, 0x2101a40, 0xc2082dc280, 0x7f1f2f573c40)
            /builddir/build/BUILD/atomic-openshift-git-0.bb7de26/_thirdpartyhacks/src/github.com/docker/distribution/registry/handlers/app.go:134 +0xd68
    github.com/openshift/origin/pkg/cmd/dockerregistry.Execute(0x7f1f2f566798, 0xc20802c6e8)
            /builddir/build/BUILD/atomic-openshift-git-0.bb7de26/_build/src/github.com/openshift/origin/pkg/cmd/dockerregistry/dockerregistry.go:60 +0x4d0
    main.main()
            /builddir/build/BUILD/atomic-openshift-git-0.bb7de26/_build/src/github.com/openshift/origin/cmd/dockerregistry/main.go:51 +0x3ea
     
    goroutine 5 [chan receive]:
    github.com/golang/glog.(*loggingT).flushDaemon(0x2102460)
            /builddir/build/BUILD/atomic-openshift-git-0.bb7de26/_thirdpartyhacks/src/github.com/golang/glog/glog.go:879 +0x78
    created by github.com/golang/glog.init·1
            /builddir/build/BUILD/atomic-openshift-git-0.bb7de26/_thirdpartyhacks/src/github.com/golang/glog/glog.go:410 +0x2a7
     
    goroutine 17 [syscall, locked to thread]:
    runtime.goexit()
            /usr/lib/golang/src/runtime/asm_amd64.s:2232 +0x1
     
    goroutine 13 [syscall]:
    os/signal.loop()
            /usr/lib/golang/src/os/signal/signal_unix.go:21 +0x1f
    created by os/signal.init·1
            /usr/lib/golang/src/os/signal/signal_unix.go:27 +0x35
     
    goroutine 16 [runnable]:
    github.com/docker/distribution/registry/handlers.func·009()
            /builddir/build/BUILD/atomic-openshift-git-0.bb7de26/_thirdpartyhacks/src/github.com/docker/distribution/registry/handlers/app.go:964
    created by github.com/docker/distribution/registry/handlers.startUploadPurger
            /builddir/build/BUILD/atomic-openshift-git-0.bb7de26/_thirdpartyhacks/src/github.com/docker/distribution/registry/handlers/app.go:975 +0x942




    [root@openshift-148 ~]# oc logs router-2-h77rf
    error: template: haproxy-config.template:223: function "matchValues" not defined


Expected results:
2. Should deploy succeed.


Additional info:
Use openshift/deployment-example image can create app successfully.

Comment 1 Johnny Liu 2016-07-08 05:11:25 UTC
@zhou, seem like you are encountering https://github.com/openshift/ose/pull/284#issuecomment-231000975, pls follow the comments update your dc config to have a try.

Comment 2 Johnny Liu 2016-07-08 06:44:07 UTC
Ignore my comment 1, the mentioned github issue is about s3 backend storage configuration, but in this bug, user even can not deploy registry/router with default configuration.

Comment 4 zhou ying 2016-07-12 03:02:22 UTC
Today, use the latest 3.3 images the issue has fixed. Please help update the status of bug. Thanks.

Comment 5 Troy Dawson 2016-07-12 13:14:14 UTC
Fixed in openshift3/ose:v3.3.0.4-1 or newer images.

Comment 6 Andrew Butcher 2016-07-12 15:59:19 UTC
*** Bug 1353830 has been marked as a duplicate of this bug. ***

Comment 7 Mike Fiedler 2016-07-12 23:12:36 UTC
Same thing is happening on 3.2.1.6.   See https://bugzilla.redhat.com/show_bug.cgi?id=1355880 and https://bugzilla.redhat.com/show_bug.cgi?id=1355885

Comment 8 zhou ying 2016-07-13 09:49:42 UTC
Confirmed with openshift v3.3.0.4, the issue has fixed.

Comment 10 errata-xmlrpc 2016-09-27 09:39:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.