Bug 1353829 - traceback message seen in ipaserver-uninstall.log file.
Summary: traceback message seen in ipaserver-uninstall.log file.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 06:40 UTC by Sudhir Menon
Modified: 2016-11-04 05:56 UTC (History)
4 users (show)

Fixed In Version: ipa-4.4.0-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:56:31 UTC


Attachments (Terms of Use)
Backtrace file created in abrt folder. (3.02 KB, text/plain)
2016-07-08 06:40 UTC, Sudhir Menon
no flags Details
sos report (1.32 MB, application/x-xz)
2016-07-08 06:41 UTC, Sudhir Menon
no flags Details
ipa server uninstall log (63.57 KB, text/plain)
2016-07-08 06:42 UTC, Sudhir Menon
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Sudhir Menon 2016-07-08 06:40:59 UTC
Created attachment 1177526 [details]
Backtrace file created in abrt folder.

Description of problem: traceback message seen in ipaserver-uninstall.log.


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64

How reproducible: Always


Steps to Reproduce:
1. Install ipa-server on RHEL7.3 | Ensure installation is successfull.
2. echo Secret123|kinit admin
3. Now uninstall ipa-server 
4. tail -f /var/log/ipaserver-uninstall.log

Actual results:
1. ipaserver-uninstall.log files displays traceback message.
2. Also see backtrace in /var/spool/abrt/ folder. 

/var/spool/abrt
[root@server abrt]# ls -l
total 8
-rw-------. 1 root root   26 Jul  8 11:37 last-via-server
drwxr-x---. 2 root abrt 4096 Jul  8 11:37 Python-2016-07-05-14:26:34-27547

Expected results:
Traceback message should be fixed.

Additional info:
Attached ipaserver-uninstall.log file and backtrace file information and sosreport

Comment 1 Sudhir Menon 2016-07-08 06:41:31 UTC
Created attachment 1177527 [details]
sos report

Comment 2 Sudhir Menon 2016-07-08 06:42:56 UTC
Created attachment 1177528 [details]
ipa server uninstall log

Comment 4 Petr Vobornik 2016-07-12 16:23:44 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6072

Comment 5 Martin Bašti 2016-07-28 07:20:28 UTC
This was added there on purpose, because there are many hidden places where sys.exit() in modules is incorrectly used from past. Without this we couldn't be able easily debug issues in installer code. It logs only as DEBUG level.

To avoid this we need refactor client and installers, but it hasn't been prioritized.

I propose wontfix for this part of BZ.


traceback reported by abrt should be fixed.

Comment 6 Martin Bašti 2016-08-01 15:19:32 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/2d4d1a9dc0ef2bbe86751768d6e6b009a52c0dc9


ABRT reported traceback fixed

Comment 8 Sudhir Menon 2016-08-05 11:10:01 UTC
Verified using ipa-server-4.4.0-5.el7.x86_64 on RHEL7.3

Note:
abrt report is not generated now which is the fix.
Although we can see the traceback in the ipaserver-uninstall.log file which is  wontfix for this part of BZ  as per comment #5.

Comment 10 errata-xmlrpc 2016-11-04 05:56:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.