Bug 135383 - "Add/remove applications" (system-config-packages) cannot read cdrom in cdrom drive
"Add/remove applications" (system-config-packages) cannot read cdrom in cdrom...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-12 09:09 EDT by Richard Baxter
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 17:02:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Baxter 2004-10-12 09:09:38 EDT
Description of problem:

"Add/remove applications" (system-config-packages) cannot read cdrom
in cdrom drive (it appears to look for cdrom in /mnt/cdrom instead of
/media/cdrom)

Version-Release number of selected component (if applicable):

FC3. Test 3. (2.92).

How reproducible:

Always.

Steps to Reproduce:
1. open system-config-packages (type root passwd)
2. choose an application to add (assuming there exists rpms which
havnt been installed yet)
3. click 'update'
  
Actual results:

Cannot find relevant Fedora cdrom

Expected results:

Reads relevant Fedora cdrom

Additional info:

If contents of mounted cdrom (/media/cdrom) are copied to /mnt/cdrom
system-config-packages can read the relevant rpms
Comment 1 Jeremy Katz 2004-10-12 15:41:54 EDT
Can you try the newer 1.2.19 package in the devel tree and see if it
does better?
Comment 2 Sven Persson 2004-10-15 04:20:19 EDT
Version 1.2.19 works at 50%. I have 2 cd-drives on /dev/hdc and
/dev/hdd. The first drive doesn´t work. If you leave /dev/hdd open and
then click OK it closes the drive and it works. But if you close the
drive yourself you have the same problem as with /dev/hdc
Comment 3 Richard Baxter 2004-10-15 22:25:48 EDT
Installing the newer 1.2.19 package (from
http://people.redhat.com/~katzj/system-config-packages/) enables my
second drive (cdrw) to be read by system-config-packages assuming the
cd is not already in the drive (/mounted) before it asks for disk x. 

[BTW I have 2 cd-drives: dvdrom and cdrw. The first (dvdrom) doesn't
work with a number of gnome programs (Not just system-config-packages,
Eg cd autoload function does not work nor have I ever managed to mount
it so that its contents can be viewed). Anaconda and gnome CD read the
first drive (dvdrom) fine.

PS I do not understand about the devel tree because I am a relative
newbie to linux]
Comment 4 Jeremy Katz 2004-10-25 09:53:02 EDT
Fixed for 1.2.20 (will be at
http://people.redhat.com/~katzj/system-config-packages/ once it builds)
Comment 5 Marius Andreiana 2005-08-19 17:02:09 EDT
Closing per comment #4 and lack of feedback. If it still doesn't work for you in
FC4 please reopen.

Note You need to log in before you can comment on or make changes to this bug.