Bug 1353841 - ipa-replica-install fails to install when resolv.conf incomplete entries
Summary: ipa-replica-install fails to install when resolv.conf incomplete entries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Abhijeet Kasurde
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 07:46 UTC by Abhijeet Kasurde
Modified: 2017-08-01 09:37 UTC (History)
4 users (show)

Fixed In Version: ipa-4.5.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:37:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
console.log (2.14 KB, text/plain)
2016-07-08 07:51 UTC, Abhijeet Kasurde
no flags Details
ipa-replica-install.log (6.19 KB, text/plain)
2016-07-08 07:51 UTC, Abhijeet Kasurde
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Abhijeet Kasurde 2016-07-08 07:46:35 UTC
Description of problem:
If you have wrong or incomplete entries in /etc/resolv.conf, ipa-replica-install fails with Stack trace.

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Edit resolve.conf to add incorrect entries
2. /usr/sbin/ipa-replica-install -U --setup-ca --setup-dns --forwarder=10.68.5.26 --ip-address=10.65.211.136 -P admin -w Secret123

Actual results:
Error with stack trace - IndexError: list index out of range

Expected results:
ipa-replica-install should suggest user to edit resolv.conf or get DNS ip using someother method or hide stack trace from user

Comment 1 Abhijeet Kasurde 2016-07-08 07:51:08 UTC
Created attachment 1177549 [details]
console.log

Comment 2 Abhijeet Kasurde 2016-07-08 07:51:34 UTC
Created attachment 1177550 [details]
ipa-replica-install.log

Comment 4 Petr Spacek 2016-07-08 12:51:21 UTC
Please provide an example of the /etc/hosts file which is causing problems.

Comment 5 Abhijeet Kasurde 2016-07-08 12:53:58 UTC
I am resolv.conf something like this

[ server1 ] # cat /etc/resolv.conf
# Generated by NetworkManager
search testrelm.test
nameserver 10.1.1.5
nameserver 10.1.1.6
nameserver 10.1.1.201
nameserver

Comment 6 Petr Spacek 2016-07-11 07:21:34 UTC
Okay, that is certainly invalid file. We can improve this but it is sooo small corner case that I would not give it huge priority for now.

Comment 7 Petr Vobornik 2016-07-12 16:16:11 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6070

Comment 8 Abhijeet Kasurde 2016-09-26 08:58:27 UTC
Just a update : 

We can fix this issue by porting this change in current IPA code -

https://github.com/rthalley/dnspython/blob/master/dns/resolver.py#L652

Comment 9 Petr Vobornik 2016-10-21 21:00:44 UTC
fixed in upstream python-dns, needs rebase to python-dns 1.15

Comment 11 Abhijeet Kasurde 2017-05-25 07:31:17 UTC
Verified using IPA version ::

# rpm -qa ipa-server python-dns
python-dns-1.12.0-4.20150617git465785f.el7.noarch
ipa-server-4.5.0-13.el7.x86_64


Steps taken for verification ::

1. Modify /etc/resolv.conf such that it contains incomplete entry
2. Try install IPA server and IPA master. Installation in both cases should succeed.

Marking BZ as verified.

Comment 12 errata-xmlrpc 2017-08-01 09:37:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.