Bug 1354142 - Huawei Modem Recognized as A CD-ROM
Summary: Huawei Modem Recognized as A CD-ROM
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 24
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-10 01:53 UTC by Khalid Moharrum
Modified: 2017-02-18 13:07 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-18 13:07:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Khalid Moharrum 2016-07-10 01:53:24 UTC
Description of problem:
When I plugin my Huawei E177, it does not appear in the NetworkManager applet.
I tried to start and enable ModemManager.service with no luck. In the Disks utility, I two Huawei devices appear, one as a Huawei SD Storage Drice and the other as a Huawei Mass Storage CD Drive with no options to umount any of them, when trying to umount them via the terminal I get a device not mounted message. it seems my modem is being recognized as a CD-ROM, dmesg outputs the following:

[ 82.002571] usb 2-1.1: new high-speed USB device number 4 using ehci-pci [ 82.089835] usb 2-1.1: New USB device found, idVendor=12d1, idProduct=1446 [ 82.089841] usb 2-1.1: New USB device strings: Mfr=3, Product=2, SerialNumber=0 [
82.089843] usb 2-1.1: Product: HUAWEI Mobile [ 82.089845] usb 2-1.1: Manufacturer: HUAWEI Technology [
82.325561] usb-storage 2-1.1:1.0: USB Mass Storage device detected [
82.325921] scsi host6: usb-storage 2-1.1:1.0 [ 82.326045] usb-storage 2-1.1:1.1: USB Mass Storage device detected [ 82.326113] scsi host7: usb-storage 2-1.1:1.1 [ 82.326221] usbcore: registered new interface driver usb-storage [ 82.334124] usbcore: registered new interface driver uas [ 83.330500] scsi 7:0:0:0: Direct-Access HUAWEI SD Storage 2.31 PQ: 0 ANSI: 2 [
83.330637] scsi 6:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2 [ 83.331448] sd 7:0:0:0: Attached scsi generic sg2 type 0 [
83.336715] sr 6:0:0:0: [sr1] scsi-1 drive [ 83.337154] sr 6:0:0:0: Attached scsi CD-ROM sr1 [
83.337445] sd 7:0:0:0: [sdb] Attached SCSI removable disk [ 83.337490] sr 6:0:0:0: Attached scsi generic sg3 type 5 [ 1070.357495] usb 2-1.1: USB disconnect, device number 4

Version-Release number of selected component (if applicable):
Fedora 24, ModemManager-1.6-0.3.rc3, NetworkManager-1.2.2-2, usb_modeswitch-2.3.0-1.

How reproducible:
All I did was that I upgraded my F23 to F24 using dnf.

Steps to Reproduce:
1. Install F23.
2. Run in terminal: dnf system-upgrade download --releasever=24 --allowerasing -y --nogpgcheck
3. dnf system-upgrade reboot
4. Plugin modem

Comment 1 Khalid Moharrum 2016-07-10 20:01:29 UTC
Just tried again on a fresh installation of F24 and got the same results.

Comment 2 alexhorov 2016-07-18 17:41:58 UTC
Hi. I have a similar problem. My bags ID 1354574. I solved the problem adding in file /usr/lib/udev/rules.d/40-usb_modeswitch.rules lines: 
#Huawei E173 add heands
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="12d1", ATTR{idProduct}=="1446", RUN+="usb_modeswitch '%b/%k"
the modem was detected as modem
to test the modem with the command in the terminal: usb_modeswitch -v 12d1 -p 1446 -J

Comment 3 Khalid Moharrum 2016-07-19 00:23:11 UTC
Thanks @alexhorov, your solution works perfectly.

Comment 4 rePeter 2016-07-21 12:27:47 UTC
Thanks for solution, I have Huawei E353/E3131 (E3272)
In Fedora 23 in /usr/lib/udev/rules.d/40-usb_modeswitch.rules  worked  generic rule:
ATTRS{idVendor}=="12d1", ATTRS{manufacturer}!="Android", ATTR{bInterfaceNumber}=="00", ATTR{bInterfaceClass}=="08", RUN+="usb_modeswitch '%b/%k'"

but it's not working in F24 and i must replace this line onto:
ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="12d1", ATTR{idProduct}=="1f01", RUN+="usb_modeswitch '%b/%k"

Comment 5 samoht0 2016-07-29 11:18:31 UTC
Looks like the generic Huawei udev rule is working again with this update (works fine now on E3372):
https://bodhi.fedoraproject.org/updates/FEDORA-2016-494a721a73
Please check and leave karma!


Note You need to log in before you can comment on or make changes to this bug.