Bug 1354200 - Verify HE storage domain can be used to create disks for VMs without major effect on the engine machine.
Summary: Verify HE storage domain can be used to create disks for VMs without major ef...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
medium
high vote
Target Milestone: ovirt-4.0.6
: ---
Assignee: Roy Golan
QA Contact: Raz Tamir
URL:
Whiteboard:
: 1309150 (view as bug list)
Depends On:
Blocks: Generic_Hyper_Converged_Host Gluster-HC-2 1400127
TreeView+ depends on / blocked
 
Reported: 2016-07-10 16:09 UTC by Raz Tamir
Modified: 2019-04-28 13:53 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-18 07:27:28 UTC
oVirt Team: SLA
rule-engine: ovirt-4.0.z+


Attachments (Terms of Use)

Description Raz Tamir 2016-07-10 16:09:51 UTC
Description of problem:
The hosted_storage is currently acts as a regular storage domain in a HE environment except the fact it cannot be removed because of the 'HostedEngine' VM.
This storage domain shouldn't be as regular data storage domain, but a system data domain


* This proposed solution might be good fix for bug #1309150


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Raz Tamir 2016-07-11 13:56:26 UTC
Might be also a good solution for bug #1315074

Comment 2 Yaniv Lavi 2016-09-14 13:13:51 UTC
Are we considering this? Is this a real solution for any bugs?

Comment 3 Roy Golan 2016-09-15 06:39:57 UTC
I think the intention of this bug is to have distinction between data domains to the data domain of the hosted engine. Not a bad idea by itself and might help clarify desgined behaviours like mentioned in Bug 1315074. BUT, implementation wise I'm not considering changing the underlying data type and introduce another one. This is risky and opened the door to lots of bugs and corner cases I believe.

The bug should really express the desired behaviour, and not what the implementation should be. Raz can you please change the subject to better express that? (and maybe chat with ydary on it before hand)

Comment 4 Yaniv Lavi 2016-09-27 14:10:48 UTC
Changed it, let me know what you think.

Comment 5 Yaniv Lavi 2016-11-15 10:34:40 UTC
We have decided in the recent discussion on this subject we will aim to make the HE storage domain similar as much as possible to any other storage domain. We wan to validate this doesn't have major issues and request you try to use this storage domain as SPM and a VM disk store.

If stress testing is done, please configure SLA since we don't expect users to do such things without this and we will warn to not stress this storage in the docs.

Comment 6 Yaniv Lavi 2016-11-16 15:27:15 UTC
*** Bug 1309150 has been marked as a duplicate of this bug. ***

Comment 7 Raz Tamir 2016-11-17 15:54:39 UTC
Currently, this [1] bug is delays our testing

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1362618

Comment 8 Raz Tamir 2016-11-22 08:37:49 UTC
Changing the summary to a correct one

Comment 9 Raz Tamir 2016-11-22 17:16:23 UTC
Re-open this bug because bug https://bugzilla.redhat.com/show_bug.cgi?id=1397189

Comment 10 Yaniv Kaul 2016-12-01 13:34:23 UTC
(In reply to Raz Tamir from comment #9)
> Re-open this bug because bug
> https://bugzilla.redhat.com/show_bug.cgi?id=1397189

That bug was closed - move back to ON_QA.

Comment 11 Raz Tamir 2016-12-01 13:42:59 UTC
I'm still having issue with this "bug".
The summery is outdated and there are many bugs revealed lately related to HE storage domain that basically caused this bug to 'FailedQA' everytime


Note You need to log in before you can comment on or make changes to this bug.