Bug 135424 - 2.6.8-1.521 fails to boot with nforce3 sata drives
2.6.8-1.521 fails to boot with nforce3 sata drives
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 13:08 EDT by Andrey Petrov
Modified: 2013-07-02 22:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:24:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrey Petrov 2004-10-12 13:08:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7)
Gecko/20040822 Firefox/0.9.3

Description of problem:
It seems the serial ata hard drive cannot be found.
I tried rebuilding the initrd with:
mkinitrd --preload sata_nv /boot/initrd-2.6.8-1.521.reiser.img.gz
2.6.8-1.521

and the ram disk then contains the modules:
/lib/sata_nv.ko
/lib/scsi_mod.ko
/lib/libata.ko

but again it won't boot.

older kernels boot fine.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.521.x86_64.rpm

How reproducible:
Always

Steps to Reproduce:
1.use yum to upgrade to the latest kernel
2.reboot into 2.6.8
    

Additional info:
Comment 1 Matt Whiteley 2004-10-13 13:46:56 EDT
Adding the following line to your /etc/modprobe.conf will fix this if
your initrd.img was in fact created correctly. I am running it now
with this kernel. Your drives will now be visible as /dev/sdY instead
of /dev/hdX.

I made my initrd with `mkinitrd -f --with=sata_nv
/boot/initrd-2.6.8-1.521.img 2.6.8-1.521`

/etc/modprobe.conf:
alias scsi_hostadapter sata_nv
Comment 2 Andrey Petrov 2004-10-14 15:32:01 EDT
Thanks a lot
That did the trick
Comment 3 Jeremy Brown 2004-10-24 19:18:34 EDT
I have the same problem with fedora core 2, so i downloaded fedora
core 3 test #3 and now the hard drives are even being detected! ive
tried various settings in the bios no luck. I have a soltek nforce3
250gb motherboard. 
Comment 4 Dave Jones 2004-11-27 15:25:06 EST
mass update for old bugs:

Is this still a problem with the 2.6.9 based update kernel ?
Comment 5 Dave Jones 2005-04-16 00:24:48 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.