Bug 135433 - Windows overlap panels
Summary: Windows overlap panels
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: metacity   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-12 17:48 UTC by Viet Yen Nguyen
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 17:51:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Viet Yen Nguyen 2004-10-12 17:48:44 UTC
Description of problem:

It is possible to have windows overlap panels. I find this quite
annoying and according to the README of Metacity, this should not be
possible: 

Q: Why is the panel always on top?
A: Because it's a better user interface, ...

Version-Release number of selected component (if applicable):

2.5.8

How reproducible:

Drag a window over the panel

Steps to Reproduce:
1. Open a terminal
2. Drag the terminal over the panel
3.
  
Actual results:

The terminal overlaps the panel.


Expected results:

The dragging should stop at the bottom of the panel. (in my case, the
panel is at the top of the screen)

Additional info:

Comment 1 Viet Yen Nguyen 2004-10-12 17:55:03 UTC
Nautilus & the panel just crashed. Nautilus was automatically
recovered, the panel did not. I restarted the panel with kill -HUP. 

And then, the windows couldn't overlap the panel anymore. 

I believe this is due to xcompmgr, which I ran half an hour ago in the
same X-session. Although I killed it, its effects must have influenced
Metacity and thus causing the original bug te occur. 

However, as xcompmgr is not included in FC3T3, this would not be
considered as a bug.


Note You need to log in before you can comment on or make changes to this bug.