Bug 135436 - SysVinit's rpm fails to install
SysVinit's rpm fails to install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 14:10 EDT by Roozbeh Pournader
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 16:18:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roozbeh Pournader 2004-10-12 14:10:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
updating SysVinit with "rpm -Uvh" fails with an error.

Version-Release number of selected component (if applicable):
SysVinit-2.85-34

How reproducible:
Always

Steps to Reproduce:
1. download SysVinit-2.85-34.i386.rpm
2. run "rpm -Uvh SysVinit-2.85-34.i386.rpm"

Actual Results:  The installation fails with the following error message: 
error: unpacking of archive failed on file /dev/initctl: cpio:
lsetfilecon failed - Permission denied


Expected Results: SysVinit should install.

Additional info: this may be due to an unclean previous installation
or update of SysVinit, since "rpm -q SysVinit" give no results, but
the files (like /sbin/shutdown) are there, with no ownership by a package.
Comment 1 Daniel Walsh 2004-10-18 16:18:17 EDT
This looks like a very confused install.  You probably have bad policy
and need to relabel.  You can try the following to cleanup

setenforce 0
install system-config-targeted 
touch /.autorelabel 
reboot
That should fix your labeling.  

Note You need to log in before you can comment on or make changes to this bug.