Bug 135500 - userpasswd gives "Unknown error" if the password is incorrect
Summary: userpasswd gives "Unknown error" if the password is incorrect
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-13 03:43 UTC by petrosyan
Modified: 2013-07-02 23:02 UTC (History)
1 user (show)

Fixed In Version: 1.80-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 12:34:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description petrosyan 2004-10-13 03:43:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041012 Epiphany/1.4.4

Description of problem:
If a user tries to change his password via using userpasswd and
mistypes his current password, the program gives an "Unknown error."
dialog message.

Version-Release number of selected component (if applicable):
usermode-gtk-1.73-1

How reproducible:
Always

Steps to Reproduce:
1. go to Main Menu / Preferences / Password
2. When prompted to enter the current UNIX password, intentionally
mistype it.
    

Actual Results:  "Unknown error" dialog appears.

Expected Results:  It should say that the user mistyped the current
UNIX password and offer another try.

Comment 1 petrosyan 2004-11-16 03:37:50 UTC
this bug is still present in usermode-gtk-1.74-1

Comment 2 petrosyan 2005-05-11 01:14:27 UTC
this bug is still present in usermode-gtk-1.79-2

Comment 3 Jindrich Novy 2005-05-11 12:34:50 UTC
This is now fixed since useermode-1.80-1.

The error was caused by the unhandled PAM_AUTHTOK_ERR error code.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.