Bug 135503 - up2date locks up in recv()
up2date locks up in recv()
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-10-13 00:43 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 21:59:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-10-13 00:43:53 EDT
Immediately after logging into my GNOME desktop, the rhn_applet has
locked up.  It appears to be the blue circle with check, except faded
after it locked up mid-animation.  Backtrace below.

Several minutes later up2date recovered and appears to be working fine.

(gdb) bt
#0  0x00934782 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00b947b1 in recv () from /lib/tls/libpthread.so.0
#2  0xf65cb7ec in sock_recv (s=0xf6608950, args=0xfffffe00) at
./Modules/socketmodule.c:1795
#3  0x00ae2991 in PyCFunction_Call (func=0xf62fe1ac, arg=0xf62fe10c,
kw=0xf65d0598) at Objects/methodobject.c:108
#4  0x00b15a20 in eval_frame (f=0x845a4ac) at Python/ceval.c:3439
#5  0x00b170ae in PyEval_EvalCodeEx (co=0xf6a69060,
globals=0xf65d0598, locals=0xfffffe00, args=0x845a280, argcount=2,
    kws=0x845a288, kwcount=0, defs=0xf6a66ed8, defcount=1,
closure=0x0) at Python/ceval.c:2663
#6  0x00b15c82 in eval_frame (f=0x845a124) at Python/ceval.c:3528
#7  0x00b169b5 in eval_frame (f=0x845a2ec) at Python/ceval.c:3518
#8  0x00b170ae in PyEval_EvalCodeEx (co=0xf6a83f60,
globals=0xf65d0598, locals=0xfffffe00, args=0x84b13dc, argcount=1,
    kws=0x84b13e0, kwcount=0, defs=0xf65ee458, defcount=1,
closure=0x0) at Python/ceval.c:2663
#9  0x00b15c82 in eval_frame (f=0x84b125c) at Python/ceval.c:3528
#10 0x00b169b5 in eval_frame (f=0x8449b04) at Python/ceval.c:3518
#11 0x00b170ae in PyEval_EvalCodeEx (co=0xf66115a0,
globals=0xf65d0598, locals=0xfffffe00, args=0x82ccf38, argcount=3,
    kws=0x82ccf44, kwcount=0, defs=0xf6a6c498, defcount=3,
closure=0x0) at Python/ceval.c:2663
#12 0x00b15c82 in eval_frame (f=0x82ccde4) at Python/ceval.c:3528
#13 0x00b170ae in PyEval_EvalCodeEx (co=0xf66117e0,
globals=0xf65d0598, locals=0xfffffe00, args=0x82d71a0, argcount=2,
    kws=0x82d71a8, kwcount=0, defs=0xf65fd058, defcount=1,
closure=0x0) at Python/ceval.c:2663
#14 0x00b15c82 in eval_frame (f=0x82d7044) at Python/ceval.c:3528
#15 0x00b170ae in PyEval_EvalCodeEx (co=0xf65e1e60,
globals=0xf65d0598, locals=0xfffffe00, args=0x84493b8, argcount=3,
    kws=0x84493c4, kwcount=0, defs=0xf6a6f1f8, defcount=1,
closure=0x0) at Python/ceval.c:2663
#16 0x00b15c82 in eval_frame (f=0x844924c) at Python/ceval.c:3528
#17 0x00b169b5 in eval_frame (f=0x84ae034) at Python/ceval.c:3518
#18 0x00b170ae in PyEval_EvalCodeEx (co=0xf6a70ea0,
globals=0xf65d0598, locals=0xfffffe00, args=0x82f42ec, argcount=2,
    kws=0x82f42f4, kwcount=0, defs=0xf65fdc78, defcount=1,
closure=0x0) at Python/ceval.c:2663
#19 0x00b15c82 in eval_frame (f=0x82f418c) at Python/ceval.c:3528
#20 0x00b170ae in PyEval_EvalCodeEx (co=0xf65feb20,
globals=0xf65d0598, locals=0xfffffe00, args=0x84a4f60, argcount=2,
    kws=0x84a4f68, kwcount=0, defs=0xf64f28d8, defcount=1,
closure=0x0) at Python/ceval.c:2663
#21 0x00b15c82 in eval_frame (f=0x84a4dec) at Python/ceval.c:3528
#22 0x00b170ae in PyEval_EvalCodeEx (co=0xf6a59160,
globals=0xf65d0598, locals=0xfffffe00, args=0x82effd0, argcount=2,
    kws=0x82effd8, kwcount=0, defs=0xf658ddf8, defcount=1,
closure=0x0) at Python/ceval.c:2663
#23 0x00b15c82 in eval_frame (f=0x82efe7c) at Python/ceval.c:3528
#24 0x00b170ae in PyEval_EvalCodeEx (co=0xf6a51e20,
globals=0xf65d0598, locals=0xfffffe00, args=0xf646f038, argcount=2,
    kws=0x0, kwcount=0, defs=0xf658de18, defcount=1, closure=0x0) at
Python/ceval.c:2663
#25 0x00ad2e6e in function_call (func=0xf646d25c, arg=0xf646f02c,
kw=0x0) at Objects/funcobject.c:504
#26 0x00abf617 in PyObject_Call (func=0xfef89fb0, arg=0xfffffe00,
kw=0xfffffe00) at Objects/abstract.c:1755
#27 0x00ac6dac in instancemethod_call (func=0xf646d25c,
arg=0xf646f02c, kw=0xfffffe00) at Objects/classobject.c:2433
#28 0x00abf617 in PyObject_Call (func=0xfef89fb0, arg=0xfffffe00,
kw=0xfffffe00) at Objects/abstract.c:1755
#29 0x00b112a0 in PyEval_CallObjectWithKeywords (func=0xfffffe00,
arg=0xf651b9cc, kw=0x0) at Python/ceval.c:3346
#30 0x00abf5de in PyObject_CallObject (o=0xfffffe00, a=0xfffffe00) at
Objects/abstract.c:1746
#31 0xf6a37e93 in ?? () from
/usr/lib/python2.3/site-packages/gtk-2.0/gobject.so
#32 0xf64745f4 in ?? ()
#33 0xf651b9cc in ?? ()
#34 0xfef8be88 in ?? ()
#35 0x0579084a in g_private_get_posix_impl (private_key=0xf65d0598) at
gthread-posix.c:276
#36 0x00cec0a8 in g_timeout_dispatch (source=0x84ac4b8,
callback=0xf65d0598 <__JCR_LIST__+260>, user_data=0xfffffe00)
    at gmain.c:3301
#37 0x00ce94fb in g_main_context_dispatch (context=0x83733c8) at
gmain.c:1942
#38 0x00ceaf82 in g_main_context_iterate (context=0x83733c8, block=1,
dispatch=1, self=0x8344898) at gmain.c:2573
#39 0x00ceb22f in g_main_loop_run (loop=0x84ac4a8) at gmain.c:2777
#40 0x003a76ce in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#41 0xf66dbda0 in init_gtk () from
/usr/lib/python2.3/site-packages/gtk-2.0/gtk/_gtk.so
#42 0x00ae2991 in PyCFunction_Call (func=0xf6acc84c, arg=0xf6fa802c,
kw=0xf65d0598) at Objects/methodobject.c:108
#43 0x00abf617 in PyObject_Call (func=0xfef89fb0, arg=0xfffffe00,
kw=0xfffffe00) at Objects/abstract.c:1755
#44 0x00b1494b in eval_frame (f=0x8347b4c) at Python/ceval.c:3713
#45 0x00b170ae in PyEval_EvalCodeEx (co=0xf6d076e0,
globals=0xf65d0598, locals=0xfffffe00, args=0xf6f70638, argcount=1,
    kws=0x0, kwcount=0, defs=0x0, defcount=0, closure=0x0) at
Python/ceval.c:2663
#46 0x00ad2e6e in function_call (func=0xf6b03f0c, arg=0xf6f7062c,
kw=0x0) at Objects/funcobject.c:504
#47 0x00abf617 in PyObject_Call (func=0xfef89fb0, arg=0xfffffe00,
kw=0xfffffe00) at Objects/abstract.c:1755
#48 0x00ac6dac in instancemethod_call (func=0xf6b03f0c,
arg=0xf6f7062c, kw=0xfffffe00) at Objects/classobject.c:2433
#49 0x00abf617 in PyObject_Call (func=0xfef89fb0, arg=0xfffffe00,
kw=0xfffffe00) at Objects/abstract.c:1755
#50 0x00ac6465 in instance_call (func=0x3, arg=0xfffffe00,
kw=0xfffffe00) at Objects/classobject.c:1999
#51 0x00abf617 in PyObject_Call (func=0xfef89fb0, arg=0xfffffe00,
kw=0xfffffe00) at Objects/abstract.c:1755
#52 0x00b14ccf in eval_frame (f=0x82ba444) at Python/ceval.c:3644
#53 0x00b169b5 in eval_frame (f=0x82d0414) at Python/ceval.c:3518
#54 0x00b169b5 in eval_frame (f=0x82aff74) at Python/ceval.c:3518
#55 0x00b170ae in PyEval_EvalCodeEx (co=0xf6f6c6e0,
globals=0xf65d0598, locals=0xfffffe00, args=0x0, argcount=0, kws=0x0,
    kwcount=0, defs=0x0, defcount=0, closure=0x0) at Python/ceval.c:2663
#56 0x00b17372 in PyEval_EvalCode (co=0xfffffe00, globals=0xfffffe00,
locals=0xfffffe00) at Python/ceval.c:537
#57 0x00b308b7 in run_node (n=0xf6fa8380, filename=0xf65d0598
"\230\204", globals=0xfffffe00, locals=0xfffffe00,
    flags=0xfffffe00) at Python/pythonrun.c:1267
#58 0x00b319e2 in PyRun_SimpleFileExFlags (fp=0x829e008,
filename=0xfefc6c1f "/usr/bin/rhn-applet-gui", closeit=1,
    flags=0xfef8cda8) at Python/pythonrun.c:862
#59 0x00b32a34 in PyRun_AnyFileExFlags (fp=0x829e008,
filename=0xfefc6c1f "/usr/bin/rhn-applet-gui", closeit=1,
    flags=0xfef8cda8) at Python/pythonrun.c:659
#60 0x00b3772e in Py_Main (argc=3, argv=0xfef8ce74) at Modules/main.c:415
#61 0x080485b2 in main (argc=-512, argv=0xfffffe00) at Modules/python.c:23


Version-Release number of selected component (if applicable):
up2date-4.3.40-1
Comment 1 Adrian Likins 2004-10-19 15:59:31 EDT
does this seem to be the same as #135735? 
Comment 2 John Thacker 2006-05-04 21:59:04 EDT
Since rhn_applet/up2date has been replaced by pirut/pup, I think it's
reasonable to close this one.

Note You need to log in before you can comment on or make changes to this bug.